Local and UpdraftPlus

Hi. I’m trying to import an UpdraftPlus backup from xxx.com into a Local WP site xxx.dev (. This seem to cause problems when importing DB. It seems like domain isn’t replaced and xxx.dev now redirects to xxx.com. I think this work a couple of months ago, but not it seems to cause some problems.

Is this a Local issue or an UpdraftPlus issue? I need to know, since our team are going to implement a new workflow. If UpdraftPlus doesn’t work with together with Local I need to adapt and do something else.

Any, please help, as I’m in a dark trench here :slight_smile:


Additional information:
It looks like there are problems regarding the path Wordpress has wheen using Local. I tried to use WP Migrate DB and manually import the SQL-file in Adminer. This seem to work after I re-save the permalinks section in Wordpress Admin. However, when I use some of the features in UpdraftPlus, everything seem to break.

After the successful WP Migrate DB import I tried to import UpdraftPlus’s plugins, then everything broke. It successfully unzipped the plugins in the right folder, but it didn’t manage to cleanup and delete the old plugins folder (screenshot 1). When I deleted this manually, I got another error (screenshot 2).

I need to know if this will be fixed either by UpdraftPlus or Flywheel. We need a working system ASAP. So please just give me a yes or a now, so I can move on to working systems.

Thank you.

Hi @yourglass,

UpdraftPlus should absolutely work with Local.

Is this in macOS or Windows?

Hi @clay

Thanks for response. Hoping we can solve this :slight_smile: This is Windows on the very newest version of Local (the one released 25th, I think(?)).

I have tried everything, but nothing seem to work. Any ideas on what I should try?

PS: I’m a web developer and I have experience, so you can talk to me technically :smiley: :wink:

I can confirm that I’m having similar issues with UpdraftPlus. macOS 10.13 (17A365), latest Local, latest Updraft, latest WP, fresh local install, staging site built using Pods 2.7 and WP-compatible custom tables.

What’s strange is as I began removing conflicting plugins (those with “include_once” warnings), new warnings for other plugins which followed the one removed began cropping up. After removing 3 plugins and seeing the issue persist, I realized it was some larger issue at hand and opted instead for the usual tar -zcvf file.tar.gz directory/* and WP Migrate DB Pro.

Of course, this issue is minimal since it’s only a 1-time task to retrieve a version-controlled package from a server which then uses standard git pull, git fetch, git push from that point forward. It remains an issue nonetheless.

@clay This is Local on Windows. It’s a fact that UpdraftPlus is, in some way, incompatible with Local. Do you have a UpdraftPlus license you can test with Local and see if you get the same errors? It looks like there are other users also having problems; both in this thread and on another thread: Unable to restore with UpdraftPlus

There you state that there are no support for UpdraftPlus. How can this be? I don’t understand that how a plugin cannot be supported by an ordinary Wordpress install, which infact Local Flywheel is. Any help, please?

@leepeterson Please keep me posted if you manage to resolve this. For us, this is a huge problem.

Additional info: this might be UpdraftPlus’ fault. Please take a look at this thread: https://updraftplus.com/forums/topic/problems-with-local-not-working-with-updraft-and-import

Anyway: We need to pinpoint where the bottleneck and what need to be fixed, by whom :slight_smile:

Hi @yourglass,

I just tried restoring the themes and plugins folder and it looks like it succeeded. I didn’t use any add-ons though.

You may want to try disabling Faster Docker Volumes and then trying to restore again. You can disable FDV by going to Preferences » Advanced.

Also, we plan on supporting importing UpdraftPlus backup files in the future. It’s just an odd flow compared to importing a single archive so we have to figure out the user experience. :slight_smile:

Hi @clay Thanks for answering :slight_smile:

Did you try restoring the database? As mentioned, that’s where my biggest problems are. The site I am migrating to, are suddenly redirecting to the old site. This is in addition to all the warnings.

Also: I don’t quite understand what you mean. Earlier in the thread you said “UpdraftPlus should absolutely work with Local.”. What do you mean by that? Is it supported or not? Why can it be fixed in an upcoming release?

I’m afraid we cannot use UpdraftPlus because of this. Very strange that a Wordpress install system doesn’t support certain plugins, especially one of the most used ones.

Sorry for the confusion!

Regarding the quote above, this means direct importing without actually using UpdraftPlus to restore. Local would handle it natively like it does with Duplicator, BackupBuddy, and generic archives (containing at least an SQL file and wp-content).

In your post above it looks like the PHP errors are from a plugin/theme restore. Can you provide the errors/output you’re seeing when you try to restore a database with UpdraftPlus?

Thanks again. Logs and different information can be found on the UpdraftPlus forums. It might look that it is a Updraft issue. Difficult to say. Are you able to pinpoint anything?


I have same problem.

Install bombed at some point to an error about something domain or something - I didn’t take a screenshot coz found Updraft often “fails” when moving domains.

Failed to rename options for site and home url… altho… it prob shouldn’t unless I used UpdraftPlus Premium Migrator!

I changed them and the admin worked but the front end didn’t

Am wondering if it has anything to do with me moving an apache site to a Local nginx install

So have wiped it all and try with an apache. Slow internet… could be ages… so if anyone has any thoughts on this in the meantime.

{insert think music}

Hmmm… am thinking this will always be prone to failure as the free version of UpdraftPlus doesn’t rename the domain throughout the install.

Looks like I will need Duplicator or use UpdraftPlus premium with the Migration add-on.

Didn’t bother trying Updraft again because don’t have a licence of the Migration add-on available

Duplicator worked flawlessly.

OK. So we can’t learn anything from this? I have tickets open over at UpdraftPlus, so I’ll keep you posted when I learn more.

I should mention I have UpdraftPlus Pro with all addons and I still experience these bugs.

1 Like

Hey all,

Just wanted to let you know I reached out to UpdraftPlus. I’ll let you know what we find.

1 Like

Thank you for this.

Hi. Any news regarding “blame”? ;D

Did you see this thread (two pages long): https://updraftplus.com/forums/topic/problems-with-local-not-working-with-updraft-and-import/page/2/

I would like to add that UpdraftPlus installations on Local Wordpress sites gives another error aswell. This happens when trying to delete old folders via admin. See previous screenshots :slight_smile: