Local cannot be re-installed

What issue or error are you experiencing?

Local does not open after one of the websites within Local froze. I turned off my local machine and now I can’t re-install Local

What steps can be taken to replicate the issue? Feel free to include screenshots, videos, etc

  1. a few days ago I opened Local (i postponed the request to update it) and the website I opened inside my Local installation froze

2.I could not close Local so I turned off my local machine

  1. Then I tried to open Local and it would not open

  2. Therefore I unistalled Local, then downloaded the latest version of Local available for Windows from your releases page and I tried to install Local again

  3. while I was installing Local again, a popup showed up saying “Impossible to decompress the files. please, try to execute the installation program again. error opening output file(s)”

How to fix it?

Let me know, thanks
Best regards,


System Details

  • Local Version: tried to install the latest version Local 9.0.3

  • Operating System (OS) and OS version:
    Windows 10 Home

Local Logs

can’t retrieve them as Local was uninstalled because it could not open anymore

Hi @Leta

Does your machine have enough available disk space or is it topped out?

Did you save a copy or copies of your site files before uninstalling?

You should still be able to access any logs that previous versions of Local left behind. See this help doc for more information on where to find those logs:

After I created some disk space, I was able to re-install Local but it still does not open

from local-lightning-verbose.log:

{"class":"addIpcAsyncListener","level":"warn","message":"Duplicate callback appears to be getting added to connectManifestWpeService:create","stringifiedCallback":"(e,t,i,n,s,r,a,o)=>this.create(e,t,i,n,s,r,a,o)","thread":"main","timestamp":"2024-06-12T08:32:17.972Z"}
{"level":"error","message":"%%userDataPath%%\\sites.json: Unexpected end of JSON input","stack":"SyntaxError: %%userDataPath%%\\sites.json: Unexpected end of JSON input\n    at JSON.parse (<anonymous>)\n    at Object.readFileSync (%%appPath%%\\node_modules\\jsonfile\\index.js:63:17)\n    at UserData.get (%%appPath%%\\main\\app\\UserData.js:1:1674)\n    at SiteDataService.getSites (%%appPath%%\\main\\sites\\SiteDataService.js:99:1483)\n    at SiteDataService.reformatSites (%%appPath%%\\main\\sites\\SiteDataService.js:99:4353)\n    at SiteData.reformatSites (%%appPath%%\\main\\sites\\SiteData.js:1:697)\n    at DataUpgrader.runUpgrades (%%appPath%%\\main\\app\\dataUpgrader.js:1:381)\n    at Object.<anonymous> (%%appPath%%\\main\\main.js:1:4963)\n    at Module._compile (node:internal/modules/cjs/loader:1271:14)\n    at Module._extensions..js (node:internal/modules/cjs/loader:1326:10)","thread":"main","timestamp":"2024-06-12T08:32:18.065Z"}
{"level":"info","message":"Electron Event second-instance","timestamp":"2024-06-12T08:32:41.432Z"}
{"class":"addIpcAsyncListener","level":"warn","message":"Duplicate callback appears to be getting added to connectManifestWpeService:create","stringifiedCallback":"(e,t,i,n,s,r,a,o)=>this.create(e,t,i,n,s,r,a,o)","thread":"main","timestamp":"2024-06-12T08:32:41.406Z"}
{"level":"info","message":"Electron Event second-instance","timestamp":"2024-06-12T08:32:57.801Z"}
{"class":"addIpcAsyncListener","level":"warn","message":"Duplicate callback appears to be getting added to connectManifestWpeService:create","stringifiedCallback":"(e,t,i,n,s,r,a,o)=>this.create(e,t,i,n,s,r,a,o)","thread":"main","timestamp":"2024-06-12T08:32:57.773Z"}

How do I fix it ?

Let me know, thanks
Best regards,


In order to refresh here and start with a clean slate could you give the below troubleshooting steps a try?

Keep us posted and we’d be happy to help further!

Thanks @Nick-B
the above steps fixed Local on my machine :grinning:


Glad to hear it @Leta! Thank you for the follow up. Happy Developing :green_heart:

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.