Local couldn't load the file list / Unable to pull or connect to WPE sites

Thank you for confirming @jhenrywaugh! We’ve heard from several other WPE users that this is the case and will likely have a stable release out today with the fix. :green_heart:

I am having a weird issue. I had upgraded to the latest release as of today, 8.1.0, but when I tried to connect to a site to pull, I kept getting an error that it couldn’t get a list of files. I tried to go back to 8.0.2 official release, and it wasn’t working either. I was able to SSH in and I was able to get a list of the sites with the API key I had.

Oddly, I had to revert back to Version 8.0.1+6490 in order to connect and get a list of files.

I tried pulling down the beta as well and it doesn’t work either. When using anything above v8.0.1, it seems to give me the same errors in the logs:
{"class":"RsyncService","level":"warn","message":"Cannot access install mysite\r\nConnection to mysite.ssh.wpengine.net closed by remote host.\r\n","thread":"main","timestamp":"2023-11-13T22:45:47.217Z"}
{"class":"RsyncService","level":"warn","message":"rsync: connection unexpectedly closed (0 bytes received so far) [Receiver]\nrsync error: error in rsync protocol data stream (code 12) at io.c(226) [Receiver=3.1.3]\n","thread":"main","timestamp":"2023-11-13T22:45:47.218Z"}

I am using an SSH key and a custom config that specifies the specific key for any ssh.wpengine.net host. If I SSH in using the same key and with the same install, I can connect just fine. I know with v8.0.2 there were some changes to ignore local config files for SSH, so not sure if this has anything to do with it.

Are you on MacOS Catalina by chance @rbaugh?

Hi, I am running version Version 8.0.2+local-beta-6503 but still can’t connect to WPE to pull a site. I am running OSX 14.1.1, here’s my log:
local-beta.log (13.0 KB)

Hi @diego2d

Can you download the latest release here:

And then reset your API credentials here:

If you’re still having problems after that please click the Download Local Logs button from the Support tab in Local. This will generate a zip archive that contains the Local log along with some other diagnostic information to help quickly zero in on any issues that Local is encountering.

@Nick-B No I am running Monterey 12.6.

So is 8.0.1 still working for you? Or are you having issues no matter the version?

If you don’t mind, please click the Download Local Logs button from the Support tab in Local. This will generate a zip archive that contains the Local log along with some other diagnostic information and we can take a deeper look.

8.0.1+6490 is working for me, but upgrading to anything after this is causing me the problems.

local-logs.zip (916.9 KB)

Is this happening when you try to connect with any sites? Or just a specific site?

Are you able to access the sites already in your Local app okay if you update?

Are there any sites you could try connecting to that you’ve never synced before to see if they work?

This happens on all sites. I can’t seem to get a list from the server(s) on any site. This issue only starts when I upgrade past 8.0.1. Right now I am staying on 8.0.1 so I can do my work and be able to sync as needed.

I assume the logs had the records from when I had upgraded. If they didn’t, I can try and upgrade, run some tests, and provide the updated logs before I revert back.

The logs are showing a lot of connection-type issues but it’s interesting that you have no problems when downgrading. I’d love to be able to see if we can replicate by trying to connect to any of your sites which will help determine if it’s specific to your setup or not. Have you opened up a ticket with WPE by chance? If you’re okay with us testing I can DM you to get some more WPE account details.

I have not opened a ticket yet as I was trying to continue on this issue thread. I am all for seeing if we can figure this out.

I just upgraded to 8.1 for grins, and I can’t connect to an existing site and just tried to connect to a new environment that I didn’t have before. Both can’t get the list of sites.

Hey @rbaugh - thanks for reaching out! Nick sent this my way this morning and I had a chance to take a look at it with the engineers.

Definitely something funny happening, though it makes sense given that Local v8.0.2 started ignoring users’ personal SSH configs - so that at least explains behavior when you upgrade and downgrade.

Can you share more about your custom SSH config/what the setup looks like?

The list of sites not appearing is interesting - that is all done outside of SSH and done via API with your username/password when you connect to WPE. If those aren’t loading, it is almost as if something is stopping Local before it can even get to the SSH parts. What is the machine/network setup like? Is this a personal machine/network or are you running on a work machine with potential firewall, VPN, etc?

Edit: When you say the list of sites, I may have misread. Do you mean the list of files that have changed when you access a specific site? Do you see a list of available sites when you visit the Connect tab inside Local?

1 Like

@austinwendt, when I read up on the 8.0.2 and SSH, I had even tried to remove my SSH config just to see if it made any difference or not. My custom config is mainly set up with rules to use specific SSH keys for domains. For my WPE set up, I am just using a wildcard for the host and then specifying my specific SSH key to use.

Host *.ssh.wpengine.net
  IdentityFile ~/.ssh/wpengine_ed.pub
  IdentitiesOnly yes

I have a similar entry for SFTP as well

Host *.sftp.wpengine.com
  Port 2222
  IdentityFile ~/.ssh/wpengine_ed.pub
  IdentitiesOnly yes

I am using the 1Password SSH agent to store my private keys, but this is working just fine on 8.0.1.

As for the “sites” comment, that should have been files. I can get the list of sites and the environments, it is just when I try and push/pull that I have the problem with getting the file/folder listing to work.

Hi @rbaugh!

I’m pretty sure that even on 8.0.1 Local wouldn’t be using those public keys specified in your SSH config, because Local is generating it’s own public key and submitting it under the hood. Any rsync/ssh commands explicitly pass that Local-specific identity file. I could be wrong about which would take precedence though - when you remove the SSH config file on 8.0.1, I’m assuming Connect still works for you?

Also, it seems your verbose logs don’t go all the way back to the last failed Connect event (the successful logs are quite long, especially for larger sites). Could you upgrade to Local Beta 8.1.1, run a Pull, and if it fails immediately upload those logs here? That would help us find the relevant logs more quickly.

Thanks! Hopefully we can get this figured out!

@adamperry I installed Beta 8.1.1 and I am still having issues getting the list of files for a site. I have uploaded the logs for it.

I removed my SSH config and downgraded back to 8.0.1 and I get a failed to get files message. When I add my config file back and try to do a pull, it works again. I attached the logs of 8.0.1 right after the failure and success.

local-beta-logs.zip (733.4 KB)
local-logs.zip (1.3 MB)

I too am facing the same issues, started happening yesterday.
Disabling magic-sync, allows us to pull/push, but magic sync is needed

{"class":"RsyncService","level":"warn","message":"Failed to create shell\r\n","thread":"main","timestamp":"2023-11-27T09:17:00.544Z"}
{"class":"RsyncService","level":"warn","message":"rsync: connection unexpectedly closed (0 bytes received so far) [Receiver]\n","thread":"main","timestamp":"2023-11-27T09:17:00.550Z"}
{"class":"RsyncService","level":"warn","message":"rsync error: error in rsync protocol data stream (code 12) at io.c(226) [Receiver=3.1.3]\n","thread":"main","timestamp":"2023-11-27T09:17:00.552Z"}
{"class":"ConnectManifestWpeService","level":"error","message":"Error creating manifest for WPE Service","sentryEventId":"b39facd7f8e84102b19c2597ac574c0b","thread":"main","timestamp":"2023-11-27T09:17:00.556Z"}
{"class":"ConnectManifestWpeService","level":"error","message":"rsync process existed with code 12","stack":"Error: rsync process existed with code 12\n    at ChildProcess.<anonymous> (%%appPath%%/main/rsync/RsyncService.js:1:1548)\n    at ChildProcess.emit (node:events:513:28)\n    at ChildProcess.emit (node:domain:489:12)\n    at ChildProcess._handle.onexit (node:internal/child_process:291:12)","thread":"main","timestamp":"2023-11-27T09:17:00.556Z"}

Additionally encountering this with both Version 8.1.0+6514 and 8.0.1.20231019.4 (pulled from a backup of the bundle in Info.plist, don’t have the app version anymore.)

Very frustrating, and effectively a show stopper. Really hindering any ability to get work done and out.