Local couldn't load the file list!

Issue Summary

After updating Local to 6.1 I can’t pull data from the server.

Troubleshooting Questions

  • Does this happen for all sites in Local, or just one in particular?
    I have the only one site so nothing to compare


Describe the steps that others can take to replicate this issue. If you have screenshots that can help clarify what is happening, please include them!

  1. select server.
  2. click pull
  3. Click “Pull from wp engine”
  4. See this: https://twtracer-gmail.tinytake.com/msc/NTY5NzU4M18xNzYxNjUwMg
  5. Click Retry
  6. See this: https://twtracer-gmail.tinytake.com/msc/NTY5NzYxM18xNzYxNjU0OQ

System Details

  • Which version of Local is being used? 6.1.0 + 5452

  • What Operating System (OS) and OS version is being used?

    • Windows 10 Professional

Hey @vadym, Welcome to the Local Community Forums!

It’s a little hard to know what’s going on specifically, can you please provide your Local Log? See this Community Forum post for instructions on how to do so:

Hi Ben, I hope this is the file you asked for
local-lightning1.log (1.0 MB)

Yeah, that’s the log!

I’m not seeing any obvious errors, but there are a large number of changes that the manifest is telling Local to make. I wonder if there’s some sort of memory limit or buffer issue that’s being encountered.

What happens if you:

  1. manually download a backup of the site from the remote environment
  2. import the backup zip into Local
  3. create a file, or make some small change
  4. start a Connect event – do you see only that one small change?

Thank you Ben for your answer. Well, I do the files update through the git. So files are always latest. I use Local just to synchronize the database. But I can’t do this because it breaks on “determining file list…”. It says “failed to access file list”

Hi, I am running into a similar issue after upgrading to 6.1.4+5521.

I try to pull the site from Flywheel and it gives me an error saying it cannot retrieve the file list. I click try again and then it says to contact support.

Troubleshooting attempted with no results:

  • Re-authenticated my account in Local/Flywheel
  • Reinstalled application
  • Delete site and re-download as if a fresh install (still have same errors)

local-lightning.log (929.7 KB)

Same error here on 6.1.4+5521. It is possible the issue lies with Flywheel? I reverted back to 6.1.3 which was working a few days ago last I pushed but the issue persists. ETA: I’m in chat with FW. I’ll report back if anything comes of it.

ETA2: known issue at FW. They are looking into it.

1 Like

Are there any updates on the issue?
I’m also encountering the issue on Local v6.1.5+5536 and it’s forcing me to upload changes to a site via FTP by hand which is extremely error prone.

@mri If you are using Flywheel it seems the issue may be on their end, I would open a ticket with them so that they can get some extra data on the error. As a workaround, it was suggested to use a vpn or a mobile hostpot as that seems to allow the connection to be made :man_shrugging:t2:not ideal, but better than nothing while they work to resolve the issue


Hello all, I can confirm that a VPN connection works as a temp solution.
Thanks, @htrammell for the tip.


I can also confirm Flywheel seems to be actively working on a fix. I was experiencing what appears to be the same issue last week on 6.1.4+5521 – couldn’t push or pull any of my Local sites to Flywheel.

With MagicSync on, first got the error “can’t load file list,” I’d hit “retry,” then it would just fail with no explanation: “Uh-oh! We ran into an issue when pulling from Flywheel.” Oddly, the issue appeared to be intermittent. When I tried again a day later, it randomly worked, then the next day was back to not working.

I opened a support ticket with Flywheel that got escalated to their Engineering team. They gave me a beta version to try, which seems to be working. It’s also working again for me after upgrading to 6.1.5 a few days ago.

I’ll follow up if I have any more insights to add. As others have said, if you’re still experiencing this issue I’d report to Flywheel to help with troubleshooting.

Hello all and thank you for your patience with this issue!

For now the most success we have seen for users experiencing this issue is the use of a VPN. For some disabling MagicSync also works, but we haven’t seen that be effective across the board.

We have tested a couple of Beta versions with specific users in our efforts to investigate this issue but those also have been met with mixed results which is why we haven’t shared them with everyone.

Thank you again for your patience and communication with us while we troubleshoot. If you have any other questions, comments or details to share feel free to drop them here!


I’m also encountering the same issue. I can confirm that only VPN works as temporary solution.

1 Like

Same issue with Local v6.1.5+5536. Disabling MagicSync and a restart did the trick with the files showing but, now I can not push.
local-lightning.log (578.6 KB)

Update to confirm I was successfully able to pull down files today without a VPN and with magic sync enabled (although it didn’t previously work even with that turned off). Not sure if any config changes happened on Flywheel’s end, but happy to not have to use my hotspot :hugs:.

running v 6.1.5+5536


I can also confirm that it seems to be working as expected since last night.

1 Like

First I could not load the file list or pull/push from/to WPengine.

Logged out of WPengine. Now I cannot connect to WPengine. Error is “Error: Something went wrong. Please try again in a few minutes”.

Issues started after after upgrading to Local 6.1.8+5621.

Tried many times. Turned off Magic Sync. Restarted Local. Still not able to log in to WPengine. Has anyone experienced the same issue and has a solution?

Issue is resolved. Started Local next day and everything is fine.

Hey everyone, the main issue we were seeing with Connect to Flywheel has been resolved. I’m going to close this topic, but if you still have issues with Connect to Flywheel or WP Engine, please reach out to their support team to help investigate, or create a new topic here and we’re happy to take a closer look!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.