Local coudn't load the file list!

What issue or error are you experiencing?

I get this error: “Local coudn’t load the file list!” when trying to push my WP-Elementor site from Local to the Flywheel domain. It had been working perfectly, pushing changes for about a month before this.

What steps can be taken to replicate the issue? Feel free to include screenshots, videos, etc

It happens when I try to push my site’s last changes to Flywheel

System Details

  • Local Version:
  • Operating System (OS) and OS version:
    Windows 10

Local Logs

Attach your Local Logs here (Help Doc - Retrieving Local’s Log)
local-lightning.log (275.9 KB)
local-lightning-verbose.log (858.0 KB)
local-lightning-verbose1.log (1.0 MB)

Security Reminder
Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

Hello @nialusby - thank you for your question :green_heart:

If you click the “Connect” icon do your sites appear in that list?

Have you tried logging out and back in to Flywheel in Local and quit/reopen Local?

Are you using a VPN?

Let me know!


Hi @sambrockway – to answer those questions, as I face the same issue –


  • Version 8.2, was happening on Version 8.1.x as well but I thought updating might fix, and failed to note full version number before my update
  • macOS 14.2.1


  • Connect tab populates with my sites
  • Logging out/in to my host (WPE in this case) has no effect
  • Quitting/reopening/restarting has no effect
  • No VPN here

Logs attached – attached, no idea why I have so many (20)

Archive.zip (825.3 KB)

Hi @rob-astute

Is this happening on a specific site on the WPE side or all of your sites? Typically we don’t see issues with FW and WPE users at the same time, so you and the poster above likely have a different root cause at play here (and different OSes), but we’ll be happy to take a look!

Can you try out our latest Beta and see if that shows any difference as well?

Hi @Nick-B – thank you for the quick response. I can confirm this is occurring for me (8.2) on multiple sites, but can confirm (to your point) this is isolated to only WPE sites for me. Flywheel connect has no issue, and I can confirm the WPE issue persists when trying multiple different sites and environments.

I installed the Beta, connected to both providers –

  • WPE ran into an issue pulling the site down as a local copy (during the database copy stage), and throws the same “list” error on a push attempt back up to the remote copy
  • Flywheel pulled locally without incident, and enumerates the list when pushing without incident

Thank you for all of the testing @rob-astute!

Could you share your updated Local Logs here for us? This time, for us to be able to troubleshoot thoroughly, please click the Download Local Logs button from the Support tab in Local. This will generate a zip archive that contains the Local log along with some other diagnostic information to help quickly zero in on any issues that Local is encountering.

No problem @Nick-B – I appreciate the support!

I’ve attached two files – the one ending in “1” is from my base Local, and the one ending in “2” is from Local Beta. Thanks again!

local-logs1.zip (1.3 MB)
local-logs2.zip (937.6 KB)

Hi @rob-astute - Do you ever utilize SSH on your WPE sites? Based on the logs there might be something broken there so we’re curious if you’re even able to connect via SSH if that’s something you’ve done before.

Hey @Nick-B – while there might be a client who uses that for their own purposes on a site that I push/pull from, I can confirm I’ve never used SSH to connect to any of my WPE/FW sites.

EDIT: I need to amend this statement, because current circumstances are now requiring me to use SSH for website changes – but it’s not part of my personal practice typically.

No problem! I’ve sent you a DM to gather some more details that I didn’t want to ask here for further testing. Thanks!

Closing the loop here for any users who come to this thread. We discovered a WPE server issue that only impacted a couple of specific sites for @rob-astute which is now resolved. :green_heart:


Hey, I’m still having the same problem.

Tried multiple versions of Local, I went back as far as 8.0.1.

Tried enabling and disabling my Surfshark VPN (Protocol Wireguard).

Tried three different sites, on two different WP Engine accounts.

Machine: Mac Apple M1 (14.3 (23D56) Sonoma)

Logs attached.

local-logs.zip (758.8 KB)

Hi @Niall

Have you reached out to WPE support directly yet? They may need to get a ticket up to their engineers based on the errors in your logs. For now, as a workaround for pulling can you download a backup and direct import that into Local?

1 Like

Ok thanks Nick.

I’m looking through the errors log now (error.log).

Is that the correct file to be checking out?

And which error lines do you reckon are causing the problem?

Thanks, Niall
(Former WP Engine Support)

This also started happening yesterday morning. I am connected to WP Engine and did my last successful pull/push the night before. No other changes have happened on my end. WPEngine has put a ticket in to investigate further.


The error I was referring to is this one in the Verbose log:

{"class":"ConnectManifestWpeService","level":"error","message":"CAPI ResponseError when creating new SSH key: Response returned an error code. 400 Bad Request","name":"ResponseError","response":{},"stack":"ResponseError: CAPI ResponseError when creating new SSH key: Response returned an error code. 400 Bad Request\n    at CAPIService.<anonymous> (%%appPath%%/main/capi/CAPIService.js:1:3817)\n    at Generator.throw (<anonymous>)\n    at a (%%appPath%%/main/capi/CAPIService.js:1:900)\n    at process.processTicksAndRejections (node:internal/process/task_queues:95:5)","thread":"main","timestamp":"2024-02-08T06:37:08.613Z"}

@hannahmwool We’re glad that they were able to get a ticket in for you! The Local Devs and WPE platform engineers are aware of this and working on a solution.

Sweet, thanks a lot for helping me with this problem folks.

Niall H,
Former WPE support.

1 Like

Hello @Nick-B and @sambrockway,

Adding here as I’m having the same issue.
I’m running Local Version 8.2.1+6583
System is Windows 11 Enterprise

I can connect to WPengine and see all my sites in the drop down but cannot pull any site for WPengine or push. The file list fails to load.
Error when trying to pull a site down from WPengine

Error when trying to push to WPEngine

Logs attached:
local-logs1.zip (734.5 KB)

Let me know if any other information is helpful.



There is a specific error in your logs we’ve been attempting to address for multiple users. Right now we have a Beta release available that some have had success with but if more troubleshooting is needed it also provides us with some enhanced logging. Could you give this a try and then follow up with any updates or fresh local logs for us to review?

Thanks @Nick-B
You should know when I downloaded the Beta version for Windows and started pulling the site (which worked) it triggered my antivirus software with the following message:

My antivirus was able to quarantine and remove the threat but wanted to make you aware of it