Local Flywheel - SSL / HTTPS not working - Getting 'This site can’t provide a secure connection' and ERR_SSL_PROTOCOL_ERROR

Issue Summary

I’m on a fairly new computer - and recently migrated from Local By Flywheel to Local.

I recently wrestled with the ‘Local Port Conflict’-error.

I had the whole thing working for a good period of time. Then I rebootet my machine, and then initially I got the same ‘Port Conflict’-error.

Running sudo lsof -i :80; I could see that it was NGINX running on port 80. So I stopped my Local-site. Exitted Local completely. Ran sudo nginx -s stop in a terminal and started Local again.

… No more Port Conflict.

BUT! Now i’m having problems with SSL / HTTPS not working. It gives me the ‘Not Secure’-warning and the red danger triangle:


And as you can see here - the certificate is trusted:


I Googled around, and I couldn’t find any good suggestions. I think it’s because of the terrible renaming from ‘Flywheel’ to ‘Local’, so all suggestions searching for ‘Local SSL / HTTPS’ are generic and not specific to this application. And if I search for Flywheel SSL / HTTPS, then all suggestions are for the legacy version of this lovely piece of software (Like this one - since there’s no SSL-tab anymore).

After a while I thought: “Whatever”, I’ll just live with that warning.
But then I tried accessing the WordPress dashboard, and got this screen:

Which was a dealbreaker.

So how do I resolve this?

Troubleshooting Questions - Solution attempts

Attempt A - Reboot
I haven’t bootet my machine (after the time I did it which caused the error to appear). The reason being that I usually have A LOT of applications running at all times, and I need to be able to resolve stuff like this, without quitting everything and starting back up.

Attempt B - Delete trusted certificate
I considered trying to find the trusted certificate and deleting it, so I could ‘retrust’ it. But I’m not sure where these are stored or if it’s a good/bad idea. Plus, when I Google for ‘Local SSL Certificate’, then I (yet again) get all kinds of generic results and nothing related to this application. So I can’t find any do’s or don’ts about it.

Attempt C - Manually trust certificate
I tried opening the certificate and set it to ‘Always trust’ the certificate:

But after I refreshed the page, it was still ‘Not Secure’.

Attempt D - Other browsers
I had tried from: Chrome, Chrome Canary, Brave and Safari. Most screenshots are from Chrome Canary. But I got the same thing in Safari:

… I tried the same things: Trust it manually and the refresh page. Same thing.

Attempt E - ‘Security’ tab in Developer Console
I checked the tab to see if I could see any further / useful information in there. But it was the same as Solution Attempt C.

System Details

Local version: 5.9.7+5156
OS: Mac - Big Sur, 11.1

Log (attached, but the latest log is about 1 hour before I got this error). So I don’t think you’re going to find anything useful in there. local-lightning.log (267.3 KB)


I could see that the critical ERR_SSL_PROTOCOL_ERROR-error, when try to access the dashboard was because there was a Port (10003) on the dashboard URL (as can be seen on the screenshot above).

So when I tried accessing this: https://mysite.local/wp-admin/ ( instead of this: https://mysite.local:10003/wp-admin/ ), then it worked.

So now I’m back to just having the ‘Not Secure’-issue.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.