Local Community

Local is so slow it's barely usable


Using Local on Macos Ventura has become very very slow (It’s barely usable) and takes ages to load each screen or go from page to page. It’s the same with every WP site I have. I use v6.7, downloaded older versions and it’s also the same. I have tried restarting the app and the machine. Nothing works. I wasn’t the case in the past.

local-logs.zip (186.0 KB)


I was using Local on Apple’s M1 chipped MBP. I had no issues before updating. After I updated to latest version, i can’t use it. Pages dont finish loading for ages. It is crazy slow. Not usable like this. Looking for a solution.

My MBP is Intel and the problem is the same…

Hi @serhat and @arnaud!

We have a handy guide here to help pinpoint and troubleshoot performance. This might be a good place to start: Troubleshooting Performance issues in Local - Local

Hello @Nick-B

I have already done that and nothing has changed.

Thanks in advance

Hi @arnaud

Are you running other developer applications simultaneously? That could also cause similar issues. Apps like MAMP, XAMPP, or Docker for example.

No, just Local

Thanks for chiming in, everybody. This is odd - definitely the first we’re hearing about any slowness, and we’re unable to reproduce any speed issues on the engineering team. We’re all using some mix of Intel/M1 machines, some Monterey and some Ventura, and on the latest build.

@arnaud - the fact that you can download an older version of Local and still see slowness tells me it isn’t specific to the release. What macOS version are you on? For the site that are slow, are there any commonalities in which PHP, database, and web server versions you’re using? This will help us try to reproduce.

@serhat - you said this is specific to the new release? Are you using Local’s Intel build or the Apple Silicon build (still requires Rosetta 2 due to dependent services)? If you download an older Apple Silicon release from localwp.com/releases, does that resolve the slowness on your machine?

@austinwendt : I am using macos Ventura. It’s not the first time Local is very slow. But right now I can’t use it anymore… Pages take min 30s-1min to load each time

Site 01 (BEB): nginx, php 7.4.1, MySQL 8.0.16
Site 02 (BEL) : Apache, php 7.4.1, MySQL 8.0.16
Site 03 (ECH): nginx, php 8.1.9, MySQL 8.0.16


Hey @arnaud - I think we might have found a lead working with another user. What is the site host/site domain for your sites? Do you know which router mode you are using, localhost vs site domains?

If you’re not sure, it will be the first line in the Site Overview - mine here is localhost:10130.

It could be because of a DNS conflict, so that’s what I’m trying to determine.

Hi there. Great you found a lead.
On my side, all the sites are using localhost not site domains such as :

  • localhost:10023
  • localhost:10004
  • localhost:10053

Thanks again

Can you try switching to Site Domain mode in Preferences > Advanced and then try launching your site again? This should change the domain to mysite.local or something similar.

If performance is still slow, could you try changing your domain away from .local to something else, like .abc?

Hey Austin,

It worked !

Switching Site Domain first gave an error msg about the site url not matching the host set in local and when fixed gave and error about an issue trusting Local SSL Certificate…

…but it the end seems to have fixed the speed issue with 3 different sites.

Thank you

1 Like

That is great news! I think we’re on to the issue, in that case… what were the site domains after you saw the improved speed? Did you leave them as .local or have to change to something else (.abc)?

I left them with .local but had to change the ssl certificate. In one case it didn’t work right way…

Thanks again

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.