Local Community

Sites suddenly very slow on Apple M1 / Silicon MacBook Pro

Issue Summary

I’m working on various sites on an Apple Silicon Mac (M1 Max MacBook Pro) in local version 6.3.0 (most recent). I have now the same issue on the second site / project. While working (local is normal working speed-wise), from one moment to the other the site is super-slow (clicking on a button > 1-3 minute loading time), both on the website, and in the dashboard. I booted everything, tried with various browsers, and also various sites/projects. This issue is just on 2 sites (my most recent ones), but I can’t solve the problem! They stay soooo slow, and I can’t finalize this client projects.

I didn’t changed anything in the setup of the affected project, I only worked in the wordpress admin as usual, then I experienced the above described issue. In both projects, it happen the same way. In the first project about a month ago. The second project just now. The only way I was able to work on the first project again, was to save the project as blueprint, took it to my old laptop (thats an old Apple Intel laptop), and created a new project with this blueprint. Now, with the second and all new projects, I would be so happy to work on it with the Apple Silicon!

Troubleshooting Questions

  • Does this happen for all sites in Local, or just one in particular? Only in particular.

  • Are you able to create a new, plain WordPress site in Local and access it in a Browser? Yes, that’s working. But I need to finalize this specific client projects.


Describe the steps that others can take to replicate this issue. If you have screenshots that can help clarify what is happening, please include them!

I don’t know how to replicate this. Does anyone else have this problem with Apple Silicon Macs? A screenshot wouldn’t help much, I think, since everything seems to be normal, only the 2 minutes of the white screen while loading the page is the problem.

System Details

  • Local version: 6.3.0+5756
  • OS version: macOS Monterey 12.2.1

Local Log

local-lightning.log (125.4 KB)

Thanks a lot for your help! Mirjam

Hi @mimmax - I haven’t heard of other users having similar issues with M1 Mac’s, but that doesn’t mean it isn’t an issue! We can dig in with you.

Just to make sure I understand, this slowness is only specific to two sites in particular? Did the slowness only start after an update to a certain version, or has it been that way across multiple versions? I don’t see anything suspicious in your log file.

If you think it is related to version 6.3.0, I would be curious if reinstalling Local v6.2.1 on your M1 Mac suddenly makes the sites faster. If this is the case, could you give that a try and let me know what you find? https://localwp.com/releases/6.2.1/


That’s really kind. Thanks for your help, Austin.

I installed 6.2.1, but I have still the same problem.

The slowness is specific to two sites (and new generated sites from blueprints with those sites). The strange thing is, that the sites were fast, and after some days/weeks working on it, they went super-slow from one moment to the other (this happened in the 1st site about a month ago, in the 2nd site last week).

I created new test sites, they are super fast. And also some old sites, which I have in Local, but I didn’t worked on since some weeks, are still fast.

I thought about a cashing problem? Maybe it could be a problem there? What I also thought about, is: When I create a project, I oftentime use Custom (php 8.0.0, nginx, MySQL 8.0.16) instead of Preferred, maybe that’s a point?

What do you think? What could I try?

Thanks a lot, Mirjam

I wonder if the version of PHP is causing problems? For the sites that have issues, can you try:

  1. Create a backup of the site by clicking “Export”
  2. Swap the version of PHP to another one (7.3.5, or 7.4.1)

After doing those things, if you are still having slowness, can you provide the PHP logs for the individual sites? You can get zip up the PHP error log from the ~/Local Sites/sitename/logs/php folder.

Unfortunately, it didn’t help to change the PHP version.
Here are the php log files:
php.zip (29.8 KB)

Thanks, Mirjam

Hi, Same for me (Monterey 12.3 - intel, not M1).

But with php 8.0 :+1:
From 15-30s to 4s !!! :rocket:

Tell me if it’s better.
Have a nice day.

Hi, for me it doesn’t helped to change the php version. Does someone has another idea? I still have the same issue…

Thanks, and a great weekend to y’all

Suddenly I have the same problem too after a couple of weeks with some sites. MacBook Pro with Intel processor, macOS Monterey 12.3.1, Local 6.3.0. Some local sites are imported from live sites and some are brand new installations. All sites are Apache, PHP 7.4.1 and MySQL 5.7.28. Any ideas what is going on? I tried to export one website and swap the PHP version but without success. I will try to repair or re-create the database tables to see if there are any speed improvements.

I don’t know if there’s a known issue on this but in the past couple weeks LocalWP has been so slow I actually have to find an alternative for local development in order to be productive at work. I really hope the LocalWP team looks into this seriously because it is crippling! I have tried all of the suggestions above and I’m still getting ~10 second page loads.

MacBook Pro 16" (2021)
Apple M1 Max Chip, 64 GB memory
macOS Monterey v12.3.1

LocalWP v6.4.0 (but have had issues with the latest few releases).

Please let me know if there’s anything I can do to help further debug this.

1 Like

Did anyone find a solution to this? Local was very fast two weeks ago, but now its unusable. The App runs OK, but the websites are as slow as an old dog. I am running macOS Monterey 12.4 on an M1 Pro with 32Gb memory. Have tried restarting, killing all other apps, different browsers etc etc.

It is interesting that this happens over time and without changes to Local… that makes me feel like it is something on the machine, but obviously multiple people are seeing it.

@Cyclobob Did anything change on your Local in the last two weeks? Is it on all sites or just sites that you’ve developed on for a while? Maybe a better question: if you create a brand new site, is it also slow?

We just recently got a new M1 Mac on the Local team, so I will see what we can find digging in.

Yes all sites are slow including a new one I jsut set up. However if I disconnect the network then things go back to being OK. Just doing some traces with wireshark to try to find out what network resources are being requested. Certainly seeing lots of errros, but nothing definitive yet.

1 Like

That is interesting - just to clarify, you’re disabling Wifi and seeing the speed increase?

Yes, disable Wifi and the speed goes back to what I was seeing when I first setup.

Reading this thread just as I was thinking about possibly jumping back on the Local bandwagon as MySQL is starting to act up in MAMP Pro (which has been M1 native since August 2021, BTW)… oh well, looks like I’ll keep my system clean of Rosetta for a now :slight_smile:

Any comment on this issue from the Local/WP Engine team? Are you looking into it? Is there a known issue? Will you be optimizing LocalWP for native M1 chips?

RE: disabling wifi to fix the issue—I’m not sure how this could even be related but it didn’t have any effect for me.

I have found a couple of things I think are pointers.

First off I am running in localhost mode because I could not get the SSL thing to work at all.

When I make a request on a local site for a page or the dashboard, my mac starts firing off DNS requests for localhost.

The local router responds that it has no records (No CNAME for localhost:10008)
So the Mac asks again
and the router replies again

This goes on for about 90 seconds and I think a time out occurs and the page just loads anyway.

Obviously with WiFi off this doesn’t happen and the page just loads.

It also doesn’t happen with MAMP PRO (thanks Philby), but MAMP Pro is too expensive for my needs right now. So nothing to do with Rosetta by the looks of it, just some dodgy stuff (in my case ) to do with localhost mode.

Managed to get the .local site domains working and the SSL cert trusted. System is back to normal with speedy responses.

Do you know what was slowing your system down/hampered local’s SSL certs from working?

Yes the slowdown was caused by running in localhost mode. The Local app should somehow suppress DNS requests when not using SSL and the .local/ domain. It seems to do this when running with SSL and the domain. I haven’t yet found out why I could not initially set up SSL and the domain I had tried several times, but gave up. I am now in a different networking environment as have moved house so I suspect there was some form of blocking at the firewall.