Local Site Shell issues - apt-get not recognized, issues installing with/without composer and more

Hi there,

I needed to create account because I’m having big issue with Local. I updated Local to new version which is 5.2.5+2498 but the same issue I had with 5.2.3 too [probably and earlier but never use this functionalities].

I’m working on Aloglia multi search for WordPress and need to create custom plugin for that. I’m not trying to install Composer but I may want to do that. So far prefer without.

When I’m launching Site Shell everything seems to be ok, but most command doesn’t work.
I tried on my main site, I tried to create new one and still nothing.

This is what I see after launching Site Shell:

I’m trying to run:

apt-get update && apt-get install -y curl

As a result I’m getting:

‘apt-get’ is not recognized as an internal or external command,
operable program or batch file.

apt-get update && apt-get install -y ca-certificates

The same as above one

php ./bin/install-dependencies-without-composer

This one is related to Algolia stuff but should work. All in proper category but giving errors. Probably due to other stuff that it doesn’t work within my containers and that there are PHP, Curl and ZipArchives issues in there.

But results starts with:
The syntax of the command is incorrect.
The syntax of the command is incorrect.

Warning: fopen(C:\Users\user_name\Local\ Sites\test-site\app\public\wp-content\plugins\algolia-search\api-client/vendor/tmp.zip): failed to open stream: No such file or directory in C:\Users\user_name\Local Sites\test_site\app\public\wp-content\plugins\algolia-search\api-client\bin\install-dependencies-without-composer on line 44

My machine is my work machine but I have full administration rights on it.
Running Local on Windows 10 [up to date]

Can anyone help why most stuff doesn’t work? I tried to google, look other issues and nothing works. I added to Windows Path Local sites, bin folder with PHP and more related to Local sites.

Thanks in advance

Is there anyone from Support Team who can help with my query? I can barely see anyone active. Why is that? I tried to contact via live chat last week, someone should look at this and nothing. Looks like Local support can not help or help only those who pay for hosting but doesn’t help with app?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.