Local Sites not showing up

Local starting OK but not finding sites that exist in Local Sites directory that were created by previous version.

Hi Simon,

Did you run AppZapper or some type of uninstaller on the previous version? If so, that will delete all of Local’s settings.

The best way to recover your existing sites is to:

  1. Rename all of the folders in your Local Sites folder to something like site-backup
  2. Create new sites for each using the existing domains and paths. So, if it was site before, you’ll use site again
  3. Browse back to the Local Sites folder and delete the newly created site folder and rename site-bakcup back to site. This is done because you can’t create sites over site folders that already exist.
  4. Right-click on the site in Local and go to “Open Site SSH”
  5. Enter myloader -p root -d /app/sql --overwrite-tables --database local … This will load in the SQL files in /app/sql
  6. Check the site and make sure it looks right

Thank you, yes I did run an uninstaller when the upgrade stalled, and your instructions restored. Many thanks.

Simon

1 Like

I’m in the same boat, except now I can’t Open SSH on any of the sites. It opens Terminal and gives me this:

Last login: Wed Apr  4 11:04:46 on ttys000
/Users/admin/Library/Application\ Support/Local\ by\ Flywheel/ssh-entry/HkSB7FGoM.sh ; exit;
-bash: touch: command not found
TimsMacBook:~ admin$ /Users/admin/Library/Application\ Support/Local\ by\ Flywheel/ssh-entry/HkSB7FGoM.sh ; exit;
Error checking TLS connection: VBoxManage not found. Make sure VirtualBox is installed and VBoxManage is in the path
Cannot connect to the Docker daemon at unix:///var/run/docker.sock. Is the docker daemon running?
logout
Saving session...-bash: date: command not found
-bash: touch: command not found

...copying shared history...-bash: cp: command not found

...saving history...-bash: cat: command not found
-bash: cat: command not found
truncating history files...
...completed.
-bash: find: command not found
-bash: shlock: command not found


[Process completed]

Any thoughts?

This has gotten a lot better - I discovered I was in the wrong path, so I’ve resolved that.
But now that I’m in the process of trying to restore the SQL files, I keep getting things like this:

Last login: Tue Apr 17 17:02:02 on ttys000
/Users/admin/Library/Application\ Support/Local\ by\ Flywheel/ssh-entry/HkBv2gV2f.sh ; exit;
TimsMacBook:~ admin$ /Users/admin/Library/Application\ Support/Local\ by\ Flywheel/ssh-entry/HkBv2gV2f.sh ; exit;
root@590edc188e41:/# myloader -p root -d /app/sql --overwrite-tables --database local

** (myloader:488): CRITICAL **: the specified directory is not a mydumper backup

root@590edc188e41:/# 

And on other sites, it will run the command and give no other output at all.

Thoughts?

The steps all seem to go smoothly until opening up the shell and using this command myloader -p root -d /app/sql --overwrite-tables --database local. I get:

command not found: myloader

It seems others have run into the same issue but no solution is provided. Do we need to install this and can you explain what’s going on in this command and/or if there is any up-to-date preferred solution for this step? I’ve also tried zipping a copy of my site, renaming it and dragging/importing to Local but I get an error that the DB ‘local’ is already created. So, neither the above instructions nor latest guidance in this forum’s FAQ on restoring sites is working for me.

I, admittedly, am probably not the one to answer the myloader/mydumper question. Perhaps @clay or someone else can chime in there.

However, my understanding of that command is that it is loading the SQL files from the site folder into the database, which we can possibly do in other ways as well. Are you able to connect to the site’s database via Adminer/Sequel Pro? If so, you can import the SQL files from /app/sql there instead, but you can omit the local-schema-create.sql file because chances are, it already exists. The myloader command would overwrite the database instead of omitting it.

Thanks Matt. The Open Adminer link does take me to a page in the Adminer web app at localhost showing the same local DB name and username as my site. I tried to zip and import the SQL files from app/sql but this didn’t work in Adminer. It looks like the recommended way to import a site now is generally to zip up the entire directory, so perhaps I should try this again this time ensuring to rename the root folder/site name to something different, and maybe that will get rid of the issue.

@clay are there updated steps to replace the myloader -p root -d /app/sql --overwrite-tables --database local instructions in your previous post? At your step 4, I have the option “Open Site Shell” and when running the above command, I get command not found: myloader. Are you able to elaborate on this and if there is another approach to loading the sql files that will work?

1 Like

Did you manage to find a solution to this? I’m currently stuck in the situation trying to move an installation from a crashed system to a new computer.