LocalWP gets stuck whenever it has to download anything (LocalWP Updates, PHP etc)

What issue or error are you experiencing?

Previously, LocalWP was working perfectly on my Apple Silicon Mac Mini. However, it will no longer work, with it getting stuck towards the end of any download.

For example, updating via the app to LocalWP 9.0.3 would get stuck and not finish, so I had to download the newest version from the website and replace it.

Whenever LocalWP tries to download anything, it just gets stuck a few MB before the download finishes. E.G. PHP 7.4.30 would get stuck at 29MB out of 35MB.

This prevents me creating any sites other than the ‘Preferred’ option where everything it needs is already downloaded.

No other developer tools other than Visual Studio Code are installed. Everything worked perfectly fine prior to recent MacOS and LocalWP updates. Last worked around March time.

Completely reinstalling LocalWP makes no difference, even when deleting the Application and all Application Support files.

Attempted a possible fix suggested in another thread where you create a site and then let it fail and manually download WordPress and pop it into the site files and then supposedly creating new sites should work as normal going forward, but this did not work.

In the error logs, after I cancel the download because it’s stuck, it does throw an error: {“class”:“DownloaderQueue”,“level”:“error”,“message”:“error when trying to download https://cdn.localwp.com/site-services-lightning/php/7.4.30+6/bin-darwin-7.4.30.tar.gz",“thread”:“main”,“timestamp”:"2024-06-02T11:34:18.363Z”}

However, if I access that URL directly, the file downloads perfectly fine in my browser.

There is also the following error: {“class”:“LightningServicesService”,“level”:“error”,“message”:“network timeout at: https://getflywheel.github.io/local-lightning-services/site-services-v2.json",“stack”:"FetchError: network timeout at: https://getflywheel.github.io/local-lightning-services/site-services-v2.json\n at Timeout. (%%appPath%%/node_modules/node-fetch/lib/index.js:1484:13)\n at listOnTimeout (node:internal/timers:569:17)\n at process.processTimers (node:internal/timers:512:7)”,“thread”:“main”,“timestamp”:“2024-06-02T10:29:37.377Z”,“type”:“request-timeout”}

But again, when I access this URL directly, it works perfectly fine.


What steps can be taken to replicate the issue? Feel free to include screenshots, videos, etc

Create a new site with custom configuration and choose a PHP version that requires downloading

OR

Wait for a LocalWP update and attempt to install the update when prompted.


System Details

  • Local Version: 9.0.3

  • Operating System (OS) and OS version: MacOS Sonoma 14.5 (M2 Chip)


Local Logs

Attach your Local Logs here (Help Doc - Retrieving Local’s Log)

local-lightning.log (126.6 KB)


Security Reminder
Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

Hi @TheJackah

Are you on a work/office network? Or is this a work-issued machine?

Do you utilize a VPN?

If you downgrade your Local version to when it was working before does the behavior revert?

Hi Nick,

I’ve found a workaround to the problem. I use 5G home broadband, as opposed to fixed line. Previously, this has worked absolutely fine with LocalWP, and everything else. It seems that recently LocalWP no longer works with this, likely what’s resulting in the “connecting” error when downloading resources, as per the previous logs provided, despite the resources being downloadable if I access them directly. Possibly a bug with LocalWP here?

As a workaround, I’ve been able to setup an L2TP VPN with a fixed IP, and LocalWP now works as expected.

That’s really interesting, @TheJackah! Thank you for coming back and sharing that. There could be several reasons why Broadband was having issues, but it’s extra curious that you’ve never had any issues until recently.

For example, a broadband connection might have stricter firewall rules or network configurations that filter traffic, but when you connect through a VPN, you might bypass these. Additionally, your Internet Service Provider (ISP) might throttle or filter traffic, but the VPN can encrypt it, making it harder for your ISP to do this. Broadband networks can also experience congestion or packet loss, which can affect the performance of certain applications. Using a VPN with optimized routing can potentially improve network performance.

Again, that all sounds well and good, but it doesn’t necessarily explain why this was never an issue until recently unless something changed with your ISP. I’ve seen at least one other Local user come in with a similar issue recently, though, so I’ll check with the Developers if they have any insight into something from our app that could have changed and contributed.