Mac - new clean installs not trusted

New clean installs not trusted but says trusted after keychain changed settings.
Running Mac os Sonoma 14.2.1 on MacBook Air M1 2020
Local Version 8.3.2+6660

Perhaps throw out Local’s Preferences, Are there any Preferences for the Local App. I checked all 3 preferences folders on the Mac.

Your help doc. change the trust policy in Keychain Access is a start, but What is my host name on Local and where would I put that? In Keychain, under Details, you can’t change anything.
I changed keychain access to trust all just to check. but it does not make trusted.


The first time I added a clean new intall after downloading Local, the trust worked. Never after that. ( I deleted all installs except for the last one, tt4)


What steps can be taken to replicate the issue? Feel free to include screenshots, videos, etc


System Details

  • Local Version:

  • Operating System (OS) and OS version:


Local Logs

Attach your Local Logs here (Help Doc - Retrieving Local’s Log)


Security Reminder
Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

Thanks for your report, @elurie!

On macOS, it’s important to follow all the certificate steps for each site you create that you want to use https for, before it will appear as trusted in Local and in your browser.

What is my host name on Local and where would I put that?

The hostname of your Local site doesn’t need to be changed in Keychain Access — you just click “Trust” and then trust the certificate in Keychain Access without altering anything else. The hostname is only used in step 4, when updating your WordPress database to use the https:// protocol instead of http://. You can find your site under “site domain” in Local (most likely https://tt4.local based on your screenshot.)

If you don’t immediately see sites as trusted or loading over HTTPS after following all steps, try restarting Local.

If you get stuck on a particular step, please let us know.

Hi Nickc,
Thank you for your reply.
I neglected to follow all the certificate steps
The last one of running Better Search and Replace.

All the best,
Eve Lurie

2 Likes

Thank you for following up and letting us know what helped @elurie :green_heart: