SSL trusted in Local and Mac keychain but not working in several browsers

What issue or error are you experiencing?

I have several websites in Local that show trusted (and I have saved the certificates in Mac keychain as always trust). But when I open the website in the browser it shows http and tells me it is not trusted. I used several browsers to check: Safari, Chrome, Chrome Canary and Firefox. All have the same problem, so it seems it is noch browser (cache) issue.

Bildschirmfoto 2023-12-28 um 15.22.27

Bildschirmfoto 2023-12-28 um 15.23.11
Bildschirmfoto 2023-12-28 um 15.23.02
Bildschirmfoto 2023-12-28 um 15.22.54


What steps can be taken to replicate the issue? Feel free to include screenshots, videos, etc

I searched the forum and saw that others had the same problem but did not find a solution.
What I tried already.

Closed Local - deleted all Local certificates in the keychain - started local again - started the trusting process - changed all certificates to always trust - started Local again. Problem keeps persisting.


System Details

  • Local Version:

Version 8.2.0+6554

  • Operating System (OS) and OS version:

Mac Sonoma - 14.2.1 (23C71)


Local Logs

Attach your Local Logs here (Help Doc - Retrieving Local’s Log)

local-logs.zip (107.6 KB)


Security Reminder
Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

Hi @MarkusZ

Are you able to manually change the URL to HTTPS and see if it will load securely?

Are you able to test your network to see if that could be cached? If you check the site using LTE data, a VPN, or an alternative network does that yield any change? You could also try restarting your network to see if that flushes it out.