Multisite is unable to update to latest Wordpress version

What issue or error are you experiencing?

Trying to update to the latest version of WordPress, but getting this error:
"Another update is currently in progress.”

We have 5 other single-sites on Local, and all of those updated without issues. So I suspect it’s something to do with the manual subsite URL configurations and SQL queries we had to go through in order to get multisite to work on Local.

What steps can be taken to replicate the issue? Feel free to include screenshots, videos, etc

Tried updating via WP admin, as well as through shell / WP-CLI suggested by Clay here.

System Details

  • Local Version: Version 7.2.1+6433
  • Operating System (OS) and OS version: macOS Ventura v13.6 (22G120)

Local Logs

Attach your Local Logs here
local-lightning.log (655.1 KB)


What version of WordPress are the sites currently on? What version are you trying to bump to 6.3.1?

If you create a new blank site in Local with a lower version and try to update that does it work okay?

The other sites have all been updated to 6.3.1. The multisite is stuck on 6.2.2, trying to get it to 6.3.1.

Are all of the other sites in Local “stopped”?

If you change your Router Mode to Localhost are you able to update? Preferences>Advanced>Router Mode>Localhost

I just tried changing it, but Local throws this error: “Warning! Multisite Subdomains are not supportd when using the Localhost Router Mode.”

I can’t open the site or WP admin now, but I do see the “Update to 6.3.1” link in Local dashboard, but that didn’t work.

I switched back to the original router mode. Not sure if related, but I forgot to mention that this error is present:

Clicking “Fix it” doesn’t do anything.

Apologies for the Localhost test, that slipped my mind.

Has that error always been present when working on the multisite you mean?

Did you build this multisite in Local or was it one that you manually imported from WPE?

I don’t recall if it’s always been present.

We did not build it in Local; it was exported from WPE, manually imported, and then configured (over a period of about 2 weeks) using various Local knowledgebase articles and community posts (like one of yours).

I found this article from WPBeginner that suggests deleting the core_updater.lock file from your database. In our application, you can manage the database via Adminer. As always, probably a good idea to back up or copy the site just in case, and then try the details here:

If you search the error Another update is currently in progress online there are some other instructions for resolving this using CLI or a plugin as well if you’d prefer.

Thanks Nick. We’ve been unable to locate a “core_updater.lock” row in wp_options. All of the help articles seem to depend on that, so I’m not sure how to proceed at this point.

Also just noticed that we’re unable to add new pages to any of the sites (primary and subdomains) – it triggers a critical error. Not sure if related but figured it was worth mentioning.

Also worth mentioning (in case anyone else has this issue): After a week of testing, the only errors we’re seeing in the logs relate to auto increment values. We’re fixing these one by one, but with 20+ subdomains it’s going to take a while.

Anyway, while researching the “Another update is in progress” issue I came across this post, where someone said their updating issue was related to the auto increment issue: Update WordPress Another update is currently in progress |

Hi @TCMB! Thank you for the updates. Glad you were able to uncover another lead for troubleshooting.

After fixing those tables are you still seeing the same issue?

Going back to this:

Also just noticed that we’re unable to add new pages to any of the sites (primary and subdomains) – it triggers a critical error.

Did you look in the logs or elsewhere to see what the actual critical error was calling out?

Hi Nick - we’ve gone through all 22 sites and fixed the auto increment issue on all tables that were throwing errors in the php error log. For posterity, those tables were:

  • wp_sitemeta
  • wp_posts
  • wp_postmeta
  • wp_redirection_404
  • wp_redirection_logs

After completing that, the “create new page” issue is now gone, and we aren’t seeing any errors in the php error log. However, we’re still getting the “Another update is currently in progress” issue, so we’re still stuck at v6.2.2.

Are there other error logs we should be monitoring?

What should I try next? Disabling plugins?

Dang! Glad to hear progress was made but sorry that you’re still stuck there.

You could try using a command like wp plugin deactivate --all --network within the Open Site Shell to be able to deactivate plugins across the multisite. Once that’s done you could try updating again to see if it goes through. If you still hit the same error, can you download a fresh set of local logs from the support tab and send those over? Then I can have the Local Devs review just in case we’re missing anything else.

Thanks Nick. While all the sites access the same group of plugins, not all plugins are activated on each site. So after I run that command and try the update, is there an easy way to restore the plugins to their prior status – or is it an all-or-nothing kind of thing?

Ahh, understood. Unfortunately, it’s kind of a nuclear command, so it would be deactivating and reactivating everything in a single go. You could break it up and make it a more detailed command or set of commands but obviously, that would take a lot of fine turning to figure out what is on/off and where.

Would you be able to share an updated log here? I’ll check with our Devs and see if they have any other thoughts.

Sure: (603.0 KB)

Hi @TCMB - We’ve been doing some testing but unfortunately have been unable to replicate the error so it might be something specific to the install. I’ll try to get the team to dig in deeper, but we’ve had some other items come up that need priority. If you’re in a hurry to get this updated, it might be worth moving it to a WPE Staging install and updating its WordPress version there as a workaround. Thank you for all of your patience and communication here!

The live site updated to 6.3.1 just fine, so this issue seems to be isolated to the Local install.

Our MySQL upgrade date has been set for next week, but after implementing the auto increment fixes we aren’t seeing anything in the error log – so I think we’re in good shape (fingers crossed).

Appreciate all the tips and followups.

1 Like

Thank you for the update @TCMB! Glad to hear that things are looking to be in good shape now.