My wplocal website is not opening in browser

What issue or error are you experiencing?

I have two websites. I restore the first by using updraft plus and it work perfect on local wp. I restore the second using the same method, but it shows the following error:

This site can’t provide a secure connection

local host sent an invalid response.

I had changed the browser, clear cache , cleared browing data, deactivate security plugin but the problem presists.
I am using Linux mint.

So I shall be grateful for any help.


Asad Ali

What steps can be taken to replicate the issue? Feel free to include screenshots, videos, etc

System Details

  • Local Version:

  • Operating System (OS) and OS version:

Local Logs

Attach your Local Logs here (Help Doc - Retrieving Local’s Log)

Security Reminder
Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

Hi @asadalizaidi

If you create a new, blank site in Local can you access that okay?

If you change your Router Mode to Localhost are you able to proceed? Preferences>Advanced>Router Mode>Localhost

Dear Nick ,

By default and I checked it again , it is in localhost. Preferences>Advanced>Router Mode>Localhost

What if you change the Router Mode back to Site Domains. Does that make a difference?

You mentioned you have at least one other site that works. If you create a new, blank site does that one open up?

Yes I tried that also, but the open site is not opening. The WP Admin in opening fine and I can edit pages also , but when trying to open the home page after any edit like view page the home page gives this error

This site can’t provide a secure connection

localhost sent an invalid response.


My other site is working perfectly with the same method Yes.
So I am attaching the log files of the site which is not opening in browser and giving error.

error.log (3.4 KB)
local-lightning.log (97.6 KB)

So you have the Router Mode set to Site Domains now? Can you also send a screenshot of the site in the browser with the error?

These are the screen shots.

The blank site works okay. I cloned my other site perfectly in local wp. Problems only arise on this site.

Based on the logs it looks like there might be a port conflict occurring. Here are some steps to help us identify and address this:

What you’ll be looking for here is to see when sites are stopped and Local is properly shut down if there are still programs running on ports 80 and 443. These may be conflicting with Local or the system may be reporting Local is still running.

Once you run that command you should see a list of listening ports. If you see a particular program making use of those ports, you can then kill that process.

After that, you should be able to retry.

Since new sites are working as expected, you could also try reimporting the site having issues. The steps would look like this:

  • Locate the site files on your machine, and save a copy of them to your desktop. If you click Go to Site Folder under your site name it should take you right to where they are located.
  • Once you have those copied, completely delete the site from Local
  • Restart Local/your machine
  • Reimport the site back into Local. You can refer here on how to Restore from only Local site files

I stopped all the sites. Closed the wp local. I re-started the PC. Then I exported this particular site to my desktop. Then I imported the zip file from my desktop with a new name.
I closed the WP local again. I re-started the PC again.Then log in to WordPress admin and visit sites from the dashboard, and it worked!!


1 Like

Glad to hear it @asadalizaidi! Thank you for following up :green_heart:

1 Like

Thanks again :blush:

1 Like