Mysqladmin: connect to localhost failed - mysqld.sock - unable to provision site

Issue Summary

Running Local on Linux Mint 19.3 - mysql error - "Uh-oh! Unable to provision site.
I hadn’t used Local for some time and went to use it and all the sites can’t connect to the database. I reinstalled mysql and it’s running. Very frustrating as Local was great!

Troubleshooting Questions

Tried re-installing Local completely including flushing / purgine all settings. Same issue.
Tried installing new site - same issue - so it’s for all sites including new ones.
Tried deleting all current sites - - same issue.

Screenshot attached


System Details

Local Version: 6.1.5+5536

OS - Linux Mint 19.3 (64 bit)

Local Log - attached.
local-lightning.log (25.5 KB)
Local Error Message

Security Reminder

Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

Hi, did you solve this issue?

Hi, yes - solved thanks. In fact it was clearly an issue with my mysql set up. I tested the most recent version of Linux Mint in VirtualBox and it worked fine. So, I just updated Linux Mint and all’s good.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.