No login possible

After changing http in wordpress to https impossible to log in again.
This always worked without problems.
But unfortunately for an almost live website, suddenly impossible to log back in as admin.
Login screen appears but login data is no longer recognized.
See in the screen : https://koch-bricksbuilder.local/wp-login.php?redirect_to=https%3A%2F%2Fkoch-bricksbuilder.local%2Fwp-admin%2Fuser%2F&reauth=1

The default which I also see appearing on other websites.
But then an empty login screen appears again.

Local version 7.0.2+6395
Windows 10
Webserver: ngins
Php version: 8.1.9
Database: MySQL 8.0.16
Wordpress: 6.2.2
Multisite: NO

error.log (1.5 KB)

Hi there @CvS -

Are you able to log in to wp-admin with One Click Admin enabled?


Hi Sam

That doesn’t work either.

I have 2 admin accounts. But with both logins the same effect.

No notification at all but just another blank login screen.

I saw the latest update from Local and hoped for a moment that this would also solve my problem.


Kind regards


@CvS Have you tried signing in with a different browser? It’s possible that it’s a cookie or caching-related issue.

1 Like

I did. Chrome- firefox – edge. All the same results.

Cache and cookies deleted. Even all the plugins temporary disabled.

In SQL wp_users all the users looks oke.

Even add a new user and login the same results. Login screen again.

Hey @CvS - happy to help dig in here! Thanks for checking the cache, I was also curious if that was an issue.

Is this on all of your sites, or just a single site? If you create a brand new site in Local, can you log in to WP Admin successfully?

My educated guess - the wp-config.php for this site still has the salts in the wrong location (our fault for that bug!) and that is why the login is being redirected.

Can you check the wp-config.php to see where your salts appear? You can quickly get to the file by clicking “Go to site folder” and navigating to app/public/wp-config.php. I’ve attached an image of my wp-config.php file; if your salts are located at the bottom of the file, can you try moving them up to where you see mine located (red box), saving the file, and then attempting to log in again? If this is the same issue, the bug was resolved in Local v7.0.2, but sites made on a version where the bug was present might need some help getting over the hump.

1 Like

The problem was on two sites.
But moving up the salts fixed the problem. Thanks.
This saves me a lot of work.
Indeed, I had already done a test with new site creation and http change.
That went without any problems.
But many thanks for this golden advice!

kind regards

This topic can be closed now.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.