Password and username not recorded

There are 2 sites in my Local machine. Let’s call them site1 and site2 . Both have worked perfectly for some time, but neither has been used for two or three weeks. They are both on my desktop computer and are the only WP sites I have. Neither has been uploaded to a web server.

I opened site2 yesterday and in the process of doing that I was asked for a username and password. Above the box asking for those details was a WP logo so I hoped it was my WP username and password required and not those for Local. I entered them, they worked and I opened the dashboard. I saw that Wordpress 5.1 was available, so I upgraded that site to 5.1. Everything seemed to work perfectly.

I then stopped site2 and tried to open site1 so that I could upgrade to WP 5.1 there as well. Again I was asked for a username and password, but although I have deliberately made them the same as for site2, they didn’t work. I tried a number of times, tried turning Local off and on, tried turning the computer off and on, but all with the same result. When I try the “forgot password” option, I’m told that there is no record of either my username or my email address.

I can still use site2 – it appears to work just as it always has.

I am able to browse the front end of site1, but cannot get to the dashboard. So I have not been able to upgrade site1 to WP 5.1.

I have the “Local Sites” folder saved in a Time Machine backup, and within that folder there are two separate folders, one for site1 and one for site2. Can they be of any use?

Hope you can suggest something not too technical to fix things!