Local Community

Php.ini.hbs loading issues

Issue Summary

Changes to the php.ini.hbs for a site are not recognized until the computer is rebooted. (starting and stopping the site or restarting the Local application is not acknowledging the changes)

Troubleshooting Questions

  • Does this happen for all sites in Local, or just one in particular?
    Yes it happens on all sites. I have even tried to create fresh ones.

  • Are you able to create a new, plain WordPress site in Local and access it in a Browser?
    Yes, everything else works as expected.

Replication

  1. Change any option in the php.ini.hbs file.
  2. Restart the site (Stop/Start)
  3. Check phpinfo() → options remain unchanged
  4. Test option to see if it is in effect with the correct setting (e.g. I tested with “upload_max_filesize”, and changes were not applied)
  5. Stop the Local app and start it again.
  6. Repeat step 3,4
  7. Reboot the computer
  8. Repeat steps 3,4 → changes are shown correctly and the test is successful (changes are in effect)

What is interesting is if I check the file specified in the “Loaded Configuration File” of the phpinfo() data, the changes are actually there, but they don’t seem to be effective in the runtime / being recognized by phpinfo().

I have even tried to change the HTTP server from apache to nginx and vice-versa, and nothing works except the reboot.

Why is only the computer reboot effective ? Is there any caching mechanism used by local that is cleared only after the system is rebooted ?

System Details

  • Which version of Local is being used?
    Version 6.3.0+5756 (Ubuntu .deb package)

  • What Operating System (OS) and OS version is being used?

    • Ubuntu desktop 18.04 (minimal install, latest updates)
  • Attach the Local Log. See this Help Doc for instructions on how to do so:
    Original log:
    local-lightning.log (158.5 KB)
    A fresh site install (cleared) log file:
    local-lightning.log (4.8 KB)
    (I noticed some phpFpm errors that might be affecting this)

Security Reminder

Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

Any suggestion on how to resolve this ?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.