Pulling a site from WP Engine


I am using Local 5.2.3+2248 and macOS 10.15.2. I have experienced two errors when pulling sites from WP Engine to local.

Issue 1 - when pulling a site from both development and production environment to local, I get the following error.

When I access the local URL, I get the standard WP installation screen. When I complete the installation process, the site works, but it has a fresh database, not the one from the WP Engine. It looks like all the files were successfully pulled to local.

Issue 2 - when pulling a site to an existing local project

Project’s details:

  • Web server: nginx
  • PHP Version: 7.3.5
  • Database: MySQL 8.0.16
  • WordPress Version 5.3.2

I have also removed the project and tried pulling it again, which resulted in the same issues.

This was the first project that I pulled local, then I have pulled four other sites from both development and production environments from WP Engine and I encounter any issue.

I would appreciate all suggestions on how to solve this issue.


Hi @martin Did you ever get anywhere with this? I’m experiencing similar issues.

Hey @AndrewS, I stopped using Local, but I think removing the application for computer and installing the most up-to-date one have solved this issue. i don’t remember any longer. A few months has passed since then.

Hope this helps.

Thanks @martin.kilarski I appreciate your response.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.