SSL on MacOS Sonoma 14.1.1 on M1 MacBook Pro doesn't work

What issue or error are you experiencing?

Local version: 8.3.2 + 6660
Chrome: Version 123.0.6312.87 (Official Build) (arm64)
Following all the instructions - error message - we ran into a problem . . .

Followed instructions here: SSL Certificate on macOS - Local

Found Key chain but certificate has a red x - “This root certificate is not trusted”

What steps can be taken to replicate the issue? Feel free to include screenshots, videos, etc

System Details

  • Local Version: Local version: 8.3.2 + 6660
  • Operating System (OS) and OS version: MacOS Sonoma 14.1.1

Local Logs

Attach your Local Logs here (Help Doc - Retrieving Local’s Log

Security Reminder
Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

Hi @rmshare

Can you try the steps outlined here to see if those help?

Same result -

Is this your first time using Local and this happened or was it working normally for awhile until an update or some other change?

No, I have been using Local for a while. I can’t get it to work. I don’t understand why the root certificate isn’t trusted & I can’t find any information or method that works. I have tried it many times with different Wordpress installations.

If you downgrade your Local version does that change anything for you?

No. It didn’t work on previous versions.

Hey @rmshare

The root certificate is never trusted under MacOS because more recent versions of Mac don’t allow for self-signed certificates (which is what Local generates and uses.)

Did you click through to the help doc that’s linked in the “Learn More” button of the error banner?

In particular, there’s a section there where you have to expand the “Trust” line and set the certificate to “Always Trust”

Can you give that a try and let us know how it goes?

Thank you for the response.

  1. Create new site.
  2. Click on “Trust” - immediate red error message - yes I have read this!
  3. Keychain access: as I noted the certificate has a “red x”
    Screenshot 2024-04-08 at 20.18.26
  4. Unable to continue the advice from the “Help document” - it will not allow Always Trust!

How do I get the certificate to Trust when it is marked with a red x? The Learn More assumes there’s no “red x” on the certificate. I don’t understand how others with a Mac get it to work.

You have to double-click through to the actual certificate and then expand the “Trust” line:

Here’s a video to help visualize the process:


Ben - thank you so very much. This is so helpful!

Got it now!

Best wishes,