Flywheel is forcing https and trust button not working

Hello guys!
I created a new site without specifying I wanted SSL (becouse I don’t need it), but Flywheel is forcing it with ssl when I click the admin or site buttons. It forces it even if i reach the local url by writing it.
In the upper side of the interface i got this message:

Heads-up! Your site is using HTTPS but the Local SSL certificate isn’t trusted.

Clicking the trust button does nothing, it keeps staying there. The same goes for the trust button under the SSL section. I press trust, the button transforms in trusted but if i change section (going for example in the database section) and going back to SSL, it is trust again.

Running windows 10 with Flywheel 2.2.4.

Please see Can't login Wordpress beacuse of https / certificate untrusted - Firefox windows 10 resolved

Browsers such as Chrome and Firefox now force HSTS/HTTPS on site domains with .dev. The redirection from HTTP to HTTPS is out of Local’s control in this case.

Hi @clay, ok I didn’t understand browsers were forcing a redirect to https for .dev extensions, I thought it was just a problem of certificate.
I have some https websites aswell to work on, what can I do for the trust button not working? This has always been a problem for me, I just avoided to work on Locals for those, but of course if I can solve it would be great. My coworker with osx just clicks the button and works like a charme.

What browser are you using?

Also, after you click on the “Trust” button you will need to restart the browser if you’re using Windows.

I’m using both firefox and chrome. The ssl trust bug is on the app, not the browser. I have now switched to .local extension and it is working with http.
To test the button, that’s the process i’m following:

  • website’s SSL settings in the Local by Flywheel app
  • press trust, the button changes to trusted
  • close browser
  • open the browser again
    Going to now redirects to the http. The button is trusted but if i change section it returns to trust again. This behavior is regardless what I do with browsers.

I could work on .dev extension for https websites and .local on http websites, but of course this is a workaround that uses the specific browser behavior, that like to avoid. I saw how it should work from my coworker and I’d like to resolve this to be able to create the website how I need it!