"Starting Local Machine" Hang... Twice

I love the functionality of Local but at this point I’m considering going back to XAMPP. It was working great and then yesterday it wouldn’t load, instead getting stuck on “Starting Local Machine” for probably 20 minutes until I gave up, tried closing it, opening it again, restarting my computer, etc. I tried removing it from VirtualBox and adding it back in, but then it got stuck on the setup process. Searched through the forums and tried every solution, command line suggestions, etc., to no avail. Finally I completely uninstalled VirtualBox and Local, reinstalled them, spent all morning today setting it back up and getting my sites back in using this post, which was surprisingly cumbersome in and of itself - I would have thought there’d be an easier way to get existing site directories back in, given that everyone who uses Local will likely at some point change computers and need to do that. The process seemed to work, everything was fine. Then I closed it, came back after a bit, and it stalled at “Starting Local Machine” again. I’ve just gone through this entire process one more time, after many expletives, and so far it seems to be working again… closed it, opened it, and everything loaded this time. So this isn’t really a support question anymore (yet, we shall see) but I wanted to add my voice to the apparent several others who’ve had this issue to make sure it’s getting attention. It’s a great setup and I love the functionality but the nicer interface definitely won’t make up for instability. Hopefully third time’s a charm, I only discovered Local a few days ago and as much as I really want to like it, I’d rather be able to get my work done.

One note is that when shutting down or restarting Windows (10), it says that VirtualBox is running and apparently Windows isn’t able to shut it down so that it can restart, which leaves me to either manually shut down VB or force the restart. Not sure if that has anything to do with the issue or might cause some kind of corruption but figured it’s worth mentioning.

Spoke too soon. Now one of my sites is giving me a 403 error saying I don’t have permission to access it on this server.

When I try myloader -p root -d /app/sql --overwrite-tables --database local from the post I linked above, the command line tells me that “myloader is not recognized as an internal or external command…”

Just tried the following and now when I click on “View Site” it redirects to the live site on my production server:

  • Backup the database.sql file in the sql folder.
  • Drop all the tables in Adminer as suggested in the comments of this post.
  • Try the command line again - still doesn’t work.
  • Manually import the database in Adminer from my backup.

Fortunately the databases should be the same, but still is there something I can do to fix this, and the rest of my sites that also give a 403 error?