Stuck Determining file list for Flywheel

Bug Summary

Yesterday after several successful pushes to flywheel, local has gotten stuck determining file list. All files times out

Steps to reproduce

Click push, select files, gets stuck determining file list

Environment Info

Describe your environment.

  • What Operating System are you using? M1 Pro Sonoma 14.4.1
  • What versions of site software (Nginx, Apache, PHP, MySQL) is used? Nginx, PHP 8.1.23, MySQL 8.0.16

local-lightning.log (793.6 KB)

  • What version of Local is installed? Version 8.3.2+6660

Supporting info

Have tried rolling back to prior versions of Local also, restarting sites, disconnecting, restarting, downloaded a backup from flywheel and uploading it and it has gotten stuck as well

Hey @gearz77 Welcome to the Local Community Forums!

I’m seeing a few entries in the log that look like:

...API is not returning expected response. \"status\" is expected to be \"ready\".\nStack:\nError: Missing JWT...

That part about a “Missing JWT” makes me wonder if you disconnect Local from Flywheel and then re-login if that would refresh the token and get it working again. Can you give that a try and let us know how it goes?

Thanks @ben.turner, I just tried to disconnect, killed the local app and restarted and reconnected it and it still is showing that same line in the logs and not getting the file list.
I did start getting a missing mailpit v1.12 pop up in local but dont see where I can add that or reinstall manually

I took a look at some other things – kicked the server and wiggled some wires. Can you try one more time?

1 Like

@ben.turner you’re amazing! that worked. I appreciate your help

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.