Local Community

Subsites are not displaying: Server not found | Multisite

Issue Summary

Clean install. The main site of the multisite is working perfect, but when I create a new subsite (subdomain) it shows server not found

Troubleshooting Questions

  • Does this happen for all sites in Local, or just one in particular?
    all installations of multisite

  • Are you able to create a new, plain WordPress site in Local and access it in a Browser?
    the main site of the multisite, not subsites

Replication

Clean install on nginx, PHP 7.3.5, MySQL 5.7.28 and 8.0.16

System Details

  • Which version of Local is being used?
    5.9.8+5191

  • What Operating System (OS) and OS version is being used?
    macOS Big Sur 11.2.1 (tried on M1 and Intel i9)

  • Attach the Local Log. See this Community Forum post for instructions on how to do so:

Do you have a screenshot of the error that you are seeing?

I’m guessing that what needs to be done is the new subsite domains need to be synced to the computer’s Hosts file. Local can query the db for those subdomains and add them when you click the Sync Multi-Site Domains to Hosts File button:

2 Likes

Thank you so much, Ben. It worked but it looks like it needs to be clicked every time the subsite is added. is there a way to automate it?

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.

I don’t think there’s a way to automate this as it currently is.