Uh oh! We ran into an issue when pulling from WP Engine. (rsync error?)

What issue or error are you experiencing?

An error message which says “Uh-oh! We ran into an issue when pulling from WP Engine.” when trying to pull a site from WP Engine using Local.

What steps can be taken to replicate the issue? Feel free to include screenshots, videos, etc

This is occuring whenever I try and pull my site from WP Engine - it only started occuring today and previously I have had no issues.

I’ve tried updating to the latest version of Local, removing the site from local, reinstalling Local and nothing is helping.

System Details

  • Local Version:

Local 7.1.2

  • Operating System (OS) and OS version:
Edition Windows 10 Pro
Version 22H2
Installed on ‎02/‎09/‎21
OS build 19045.3324
Experience Windows Feature Experience Pack 1000.19041.1000.0
Device name N010
Full device name N010
Processor 11th Gen Intel(R) Core™ i7-11370H @ 3.30GHz 3.30 GHz
Installed RAM 16.0 GB (15.7 GB usable)
Device ID 1AFA2EFF-D45C-4192-B7F7-29E468CE2213
Product ID 00330-80000-00000-AA858
System type 64-bit operating system, x64-based processor
Pen and touch No pen or touch input is available for this display

Local Logs

local-lightning.log (790.8 KB)

The error that occurs in the local log is here, though I’ve no idea what this means or where to begin to diagnose it:

{"thread":"main","class":"Process","process":"mysql","level":"warn","message":"2023-08-29T09:46:02.442134Z 0 [System] [MY-010931] [Server] %%resourcesPath%%\\lightning-services\\mysql-8.0.16+6\\bin\\win64\\bin\\mysqld.exe: ready for connections. Version: '8.0.16'  socket: ''  port: 10004  MySQL Community Server - GPL.","timestamp":"2023-08-29T09:46:02.439Z"}
{"thread":"main","class":"RsyncService","message":"      3 [main] rsync 1548 child_info_fork::abort: \\??\\%%resourcesPath%%\\bin\\rsync\\win32\\cyggcc_s-1.dll: Loaded to different address: parent(0x720000) != child(0x700000)\n","level":"warn","timestamp":"2023-08-29T09:46:06.213Z"}
{"thread":"main","class":"RsyncService","message":"rsync: fork: Resource temporarily unavailable (11)\nrsync error: error in IPC code (code 14) at pipe.c(65) [Receiver=3.1.2]\n","level":"warn","timestamp":"2023-08-29T09:46:06.252Z"}
{"thread":"main","class":"WPEPullService","sentryEventId":"e97321660fd147c59b485f32b79216a8","level":"error","message":"Error in WP Engine connect: ","timestamp":"2023-08-29T09:46:06.281Z"}
{"thread":"main","class":"WPEPullService","level":"error","stack":"Error: rsync process existed with code 14\n    at ChildProcess.<anonymous> (%%appPath%%\\main\\rsync\\RsyncService.js:1:1548)\n    at ChildProcess.emit (node:events:527:28)\n    at ChildProcess.emit (node:domain:475:12)\n    at ChildProcess._handle.onexit (node:internal/child_process:291:12)","message":"rsync process existed with code 14","timestamp":"2023-08-29T09:46:06.282Z"}

Anyone know what might be causing this error? I checked other threads on this error and nothing seems to help. This is holding me up on a time-critcial project so I’m very worried.

Many thanks.

Having the same issue here. I’m on the latest version of Local on macOS and restarting the app does nothing to fix the problem. I can’t seem to pull any of my sites.

Hi @digisquid and @mattrosebcc!

To start off have you tried resetting your API credentials? Details here:

If you’re still having trouble, in order to move things along can you try downloading a backup and direct importing that into Local to see if that works? We still want to help solve your Local Connect issues, but this may be a viable workaround just to help you get things going.

Thanks, Nick. Unfortunately resetting my API credentials didn’t help. In fact, it made things quite a bit worse since I manage several dozen sites and it looks like each one needs to be reconnected and configured now.

And, so far at least, none of the sites I’ve reconnected can pull from WP Engine.

Have you ever been able to pull sites from WPE? Or was it working normally before and then suddenly you weren’t able to pull anything? As in did it suddenly stop working after a local update, update on your machine, or are you using a new machine to pull?

What macOS version are you on? Can you share a copy of your Local log? Retrieving Local’s Log File

Yeah, I’ve been using WP Local for a while. So I’ve got around 70 sites configured in there and connected to WP Engine. Pushing and Pulling is far from perfect, but it did at least work up until recently. But now I can’t push or pull anything at all.

It will connect to wP Engine and perform a backup if I try to push but then it doesn’t actually upload anything. Pulling, on the other hand, seems to fail right away.

I’m on Local 7.1.2+6410 running on macOS Ventura 13.4.1.

Do you know if it stopped working after a Local update or some sort of update on your machine?

If you downgrade your Local version to 7.1.0 does it work?

The error first happened after the most recent update, but I can’t say for sure that the update caused the issue. I did, however, try downgrading to a previous release and that didn’t help. I still have the push/pull issue on Local 7.1.0 for Apple Silicon MacOS.

When you go to the releases page are you using the MacOS install or the Apple Silicon install?

Apple Silicon

Okay great, thank you! Can you share a copy of your Local Log? For us to be able to troubleshoot thoroughly, please click the Download Local Logs button from the Support tab in Local. This will generate a zip archive that contains the Local log along with some other diagnostic information to help quickly zero in on any issues that Local is encountering.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.