Unable to add new themes and new plugin

I have been facing this problem from last 5 days please help me out from this…
i have reinstall local many of the times to get rid of this problem but can’t ,
if you are going to advise me to restart local machine then please tell me the steps…

Hi @thevikashgautam

We would be happy to assist with your Local troubleshooting! Could you provide some more details to help us take a further look?

  • What is your OS?

  • What version of Local are you on?

  • Please attach a copy of your Local Logs

Keep us posted and we’d be happy to help further!

windows 11
local 7.0.1
local-logs.zip (7.5 KB)

hey please reply

Hi @thevikashgautam

Just a heads up that since Local is a popular and free product, we do not offer priority support. We always try to assist with issues here the best we can in a timely manner, but troubleshooting and communication may take additional time.

Looking at your logs, there may be something blocking Local. Do you have any antivirus, security, or firewall applications that could be interfering?

More details about troubleshooting this here: Router Mode

Are you running other developer applications simultaneously? That could also cause similar issues. Apps like MAMP, XAMPP, or Docker for example.

yes there is an antivirus installed in my pc name protegent but a few days before the local was running without having any problem…
no xampp is not installed in my laptop
even i have reset my pc to get rid of this problem still i am getting this

protegent is not installed now as i have reset my pc.

If you create a new, blank site in Local and try to install a plugin does the same thing happen?

Is there any change if you switch your Router Mode?

Are you using Apache as the server type?

yes the same thing is happen i tried to create the new site again and again,
the speed of loading the page become too low when i click on add new plugin.
ya i have tried by using apache and nginx as a web server but no solution

i have not try router mode is there any step then please let me know

I sent a link above but you can find more details about Router Mode here: What is Router Mode? - Local

You can also try downgrading your Local version: Downgrade Local Version - Local

yes i have check just see the images same problem is there

and yes i have already check with different versions of local but the problem is not yet solve

Are you able to try a different network, VPN, or use a cellular hotspot? Usually this type of error is indicative of something blocking Local, which we’ve just about ruled out, or some type of network connection issue.

no this is not a network problem i have check this through cellular data and from wifi still the same problem

can you please tell me that restart local machine refers to the same - uninstalling the local then install again.

If you want to completely uninstall and try to start fresh, you can follow these steps:

  • Export any sites that you have on Local and save them to a folder somewhere on your computer.

  • Fully uninstall Local from your computer with the instructions here

  • Install the latest version of Local on this link.

  • Once installed, please restart the computer.

  • When the computer is restarted and turned on, close any applications that automatically run in the background (AntiVirus, Firewall, and other Developer applications included).

  • Check and see if the issue still persists. If so, please provide us with an updated log. Retrieving Local’s Log File

still not get the solution
local-logs2.zip (9.2 KB)

Hi @thevikashgautam

The logs still indicate something is blocking here:

2023/06/13 20:08:06 [error] 26412#14656: *516 connect() failed (10061: No connection could be made because the target machine actively refused it) while connecting to upstream, client: ::1, server: first-website.local, request: "GET /wp-includes/js/wp-emoji-release.min.js?ver=6.2 HTTP/1.1", upstream: "", host: "first-website.local", referrer: "http://first-website.local/wp-admin/themes.php"

Have you checked this?

If you stop all sites and quit Local, and run the command below do you see anything running that could be causing a conflict?

  • netstat -ano

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.