Unable to get into admin panel once local is downloaded and info is put into local

What issue or error are you experiencing?

Unable to get into admin panel once local is downloaded and info is put into local

What steps can be taken to replicate the issue? Feel free to include screenshots, videos, etc


System Details

  • Local Version:

  • Operating System (OS) and OS version:
    Windows 10


Local Logs

Attach your Local Logs here (Help Doc - Retrieving Local’s Log)

I am not sure how to attach logs?


Security Reminder
Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

Hi @stewtech

Are you running other developer applications simultaneously? That could also cause similar issues. Apps like MAMP, XAMPP, or Docker for example.

Do you have any antivirus, security, or firewall applications that could be blocking Local?

More details about troubleshooting this here: Router Mode

Can you share your Local Log here? Retrieving Local’s Log File

I was running xampp but I uninstalled xampp and local and then reinstalled local.

I do have webroot running but why would that block local?

I tried the router mode due to it using the same ports but since I just uninstalled xampp I was hoping that would eliminate that.

I tried to load my log and can’t figure it out even with the documentation.

How would I stop webroot?

For your Local Logs if you click on the Support tab on the left side of your app (circle with a question mark ?) and then scroll down there will be a little spot that says Download Local Log. This creates a zip file with all of your logs in it.

The logs may not be necessary as it sounds like there could potentially be a couple of conflicts at play. I’ve never used Webroot so you may need to consult with them or their documentation but they might have a way to “allow” Local. Security applications will sometimes block connections and processes just as part of their nature until something is “allowed” or given permission.

1 Like

I tried it with webroot uninstalled but no luck. I found someone who had a similar problem but they weren’t using xampp and they were using linux os. I am hoping that you may have heard of this or have knowledge that may translate this for my issue:

It took me quite a while to figure it out but in the end I did. My LocalWP routing mode was on “Domains” at first but then I had switched it to “localhost” and I was guessing that this might have left the router still listening to port 80 due to some malfunction. After I confirmed that Apache is listening to port 80, I added new records of nonexistent domains to the hosts file and these got pinged directly to their proper address that I set there. This made me have a really thorough look at the hosts file and it was then that I realized the two locally set up sites that I tested are both missing, but most of the others are still there. In initial checks I only saw that there are plenty of records which lead me to believe the file is intact.

Conclusion:

LocalWP managed to delete some of my /etc/hosts records. LAMP and LocalWP can work together but have in mind to create a copy of your hosts file before LocalWP installation.

Hi @stewtech

It sounds like what they are describing is a port conflict. Here are some steps to help identify and address this:

  • Stop all sites that are running in Local

  • Force quit Local

  • (If using Mac) Run the command lsof -nP -iTCP -sTCP:LISTEN

  • (If using Windows) Run the command netstat -ano

What you’ll be looking for here is to see when sites are stopped and Local is properly shut down if there are still programs running on ports 80 and 443. These may be conflicting with Local or the system may be reporting Local is still running.

Once you run that command you should see a list of listening ports. If you see a particular program making use of those ports, you can then kill that process by running sudo kill -9 XXX where XXX is the PID number of that process. (On Windows you will use taskkill /F /pid XXX where XXX is the PID number of that process)

There are also some more details around this and other troubleshooting steps at this link if needed: Stopping Whatever Is Listening On Port 80.

If you’re still having issues, please share your full local logs mentioned in my comment here.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.