Unable to start site - Can't connect to MySQL

What issue or error are you experiencing?

Unable to start a site. Attaching the logs and the screenshot. It seems as though it won’t start mysql. I tried to update PHP first and then when I try and start it this happens. I tried changing it back too and it failed.

local-logs2.zip (82.5 KB)
Screen Shot 01-26-24 at 09.58 AM


What steps can be taken to replicate the issue? Feel free to include screenshots, videos, etc


System Details

  • Local Version:

  • Operating System (OS) and OS version:


Local Logs

Attach your Local Logs here (Help Doc - Retrieving Local’s Log)


Security Reminder
Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

Hi @darwinstudios

If you change your Router Mode to Localhost are you able to proceed?

Preferences>Advanced>Router Mode>Localhost

If you create a new, blank site in Local can you access that okay? If you can, then you may want to try reimporting the site getting the errors. The steps would look like this:

  • Locate the site files on your machine, and save a copy of them to your desktop. If you click Go to Site Folder under your site name it should take you right to where they are located.
  • Once you have those copied, completely delete the site from Local
  • Restart Local/your machine
  • Reimport the site back into Local. You can refer here on how to Restore from only Local site files

I just created an additional topic before seeing this one.

I am experiencing the same issue. I have done the following:
Disabled Firewall
Disabled VPN
Disabled AV
Rebooted multiple times
Reinstalled and purged data multiple times.

Open to any suggestions.

Hi @richardkrone

I’m not sure that your issues are related. I’ve followed up on your post for more info!

This is not working. I am importing and now getting these errors upon importing. My site is not there when it starts:

• F:/Local WP Sites/graceway3/app/sql/avatar.sql
• F:/Local WP Sites/graceway3/app/sql/crawler_blacklist.sql
• F:/Local WP Sites/graceway3/app/sql/crawler.sql
• F:/Local WP Sites/graceway3/app/sql/img_optm.sql
• F:/Local WP Sites/graceway3/app/sql/img_optming.sql
• F:/Local WP Sites/graceway3/app/sql/url_file.sql
• F:/Local WP Sites/graceway3/app/sql/url.sql

meaning it starts and the site is a blank install without my work.

I am so confused. Is the main sql file stored somewhere other than SiteFolder/app/sql ?

The sql file in there (local.sql) is from 11/28/2023. I am positive it was updated in the last couple of weeks. Is the site sql file somewhere else? I even have backups on my computer and when I go back to restore, the file is not showing updated since 11/28/2023. Any ideas?