Uninstalled Local, Not able to Install again

I had contacted Flywheel support because Local wasn’t “updating” correctly. They suggested Uninstalling then Reinstalling and checking here if that didn’t work. I uninstalled, now when reinstalling it won’t install — just spins and spins. Unfortunately I just now found the correct way to uninstall (from Virtual Box first) https://getflywheel.com/wordpress-support/uninstall-local-on-macos/. What I had done was took Local and dragged it to the trash (on a Mac), then took VirtualBox and dragged it to the trash. Then emptied the trash. So evidently I messed up and would like to know how to fix it. Thanks for any help.

What happens when you try to install it again?

Just so you know, this process you linked, erases every kind of trace from Local in the system. All the files are stored in the folders from Local, and the databases are kept in the Virtual Machine, with backups on the site’s folder.
I don’t get why you can’t install it again… Even if you started dragging the Local app to trash, the VM should be on VirtualBox, and you should be able to remove it, and continue with the steps on the link you sent.

My only guess is that VirtualBox might leave some files from the local-by-flywheel machine on the system, so when you uninstall Local first, you lose the ability to start the VM and maybe to completely remove it without going manually into each folder and deleting them. But have you tried to continue the process from the link, even if you started with deleting Local?

Hi, thanks for responding. I will be able to try again in a few days. But the problem is that I “uninstalled” before finding that link. I was given advice to put both of those items in the trash. I simply did that; I did not do as described in the link. When I can, I will try to restore my Mac from Time Machine. Then, I will uninstall correctly and see if it works this way.

1 Like

I did this exact thing. Did you find a solution?

Actually, I fixed it. Just putting this out there in case anyone else runs into the same problem. Just to summarize, I wanted to reinstall Local and moved both Local and VirtualBox to the trash (Mac) and deleted from there. When I tried to reinstall Local again it would get stuck on trying to start the local system. It didn’t reinstall VirtualBox with it.

So I reinstalled VirtualBox separately and then installed Local and it worked.


I didn’t have any files to save, so I’m not sure how it would work if you had a bunch of sites you had been working on.

1 Like

No solution worked. It has been a while but here is what I remember I did: I have a Mac on which I use Tme Machine. First I migrated the one WordPress install I needed to save to a spot on Flywheel, to preserve it. After manually backing up any very recent files, I retstored my computer to the day before I made the mistake, then added back the new files. I think I then followed the more accurate directions.

I realized I could not depend on Flywheel Local or Flywheel Support for important work. I migrated the one saved site in development to WP Engine, where I had been originally. Worth the money since I have never had any bad advice from their customer support.

Hope this helped. Good luck.

I can’t believe I forgot about Time Machine. That would have been a pretty easy solution. Thanks for the input! Sorry it didn’t work out for you!

1 Like

:+1: All good. Hopefully it worked out for you too!