UPDATE MACOS15 — Error 502 / apache

What issue or error are you experiencing?

Since installing MAcOS 15 Beta on my Mac
all my sites no longer load and display an error 502
However, each database can be accessed normally from AdminerEvo…

On the interface I get these errors :

/Users/pascal/Library/Application Support/Local/run/hnPPBzx-b/mysql/mysqld.sock

Database name
Unable to find DB_NAME in app/public/w-config.php
Default: local

Unable to find DB_USER in app/public/wp-config.php
Default: root

Unable to find DB_PASSWORD in app/public/w-config.php
Default: root

I reinstalled, Local and reassembled the sites and nothing changed …
Then I noticed that if I switch to nginx instead of apache
it works (adapting the htacess of course…)

Do you have any feedback on this proble

Translated with DeepL.com (free version)

What steps can be taken to replicate the issue? Feel free to include screenshots, videos, etc

System Details

  • Local Version:

  • Operating System (OS) and OS version:

Local Logs

Attach your Local Logs here (Help Doc - Retrieving Local’s Log)

Security Reminder
Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

Hi @PascalDUBOIN

Are you able to create a new, blank site using Apache instead of NGINX and does that work okay?

If so, you could try manually re-importing a previous Apache site into that install with the steps here:

Manually Import a Local Site

HI_NICK : No unfortunately

Could you provide some more details to help us take a further look?

  • What is your OS?

  • What version of Local are you on?

  • Please attach a copy of your Local Logs

Keep us posted and we’d be happy to help further!

Thank you very much for your help and responsiveness

What is your operating system: MacOS 15.0
What version of Local do you use? Version 9.0.3+6684
Please attach a copy of your local newspapers:

local-logs.zip (70.5 KB)

In order to refresh here and start with a clean slate could you give the below troubleshooting steps a try?

  • Export any sites that you have on Local and save them to a folder somewhere on your computer.

  • Fully uninstall Local from your computer including any configuration folders.

  • Install the latest version of Local on this link.

  • Once installed, please restart the computer.

  • When the computer is restarted and turned on, close any applications that automatically run in the background (AntiVirus, Firewall, and other Developer applications included).

  • Check and see if the issue still persists. If so, please provide us with an updated log. Retrieving Local’s Log File

Keep us posted and we’d be happy to help further!

that’s what I did when I noticed the problem

I’ll try again tomorrow morning following your checklist - Thank you.

local-logs.zip (69.4 KB)

Do you have any antivirus, security, or firewall applications that could be blocking Local?

Are you running other developer applications simultaneously? Apps like MAMP, XAMPP, or Docker for example.

No Nothing

If you change your Router Mode to Localhost are you able to proceed with an Apache site?

Preferences>Advanced>Router Mode>Localhost

Hello, in this case, yes, a new site under apache is displayed correctly.

Okay thank you @PascalDUBOIN! So that should be a suitable workaround for now but I’m checking with our team on any potential conflicts with the latest Mac update.

OK thank you. Please note that GarminExpress no longer works since the update - Kind regards

GarminExpress no longer works on your machine since the update to MacOS15? Have you contacted them about this as well?

Hello, in the meantime I was working in NGIX mode.
Following the Local 9.04 update and OS 15 beta 2, the apache mode is working normally again… I don’t know which of the two provided a solution, but it’s working.
Thanks for your help - Kind regards

Sounds good thank you for the follow up @PascalDUBOIN :slight_smile: