Local Community

[Urgent] NET::ERR_CERT_INVALID on MacOS Monterey

Hi, https not working, I’ve tried everything I found on the web. Problem occurred since a few weeks but I didn’t need https till today.

Updating Wordpress
Updating Local
Adding new ca-bundle.crt
Keychain Access, always trusting the certificate.
Replacing URLs in DB
Read all the FAQ articles on SSL, nothing worked.

In local SSL appears trusted, but when I open the website I get the usual error Your connection is not private, NET::ERR_CERT_INVALID.

The bigger problem is that I can’t make API requests and my whole implementation is put on hold because of this.

Please, need help asap.

anyone, please?

Hey @cristian.roman – Making HTTPS connections from a WordPress site in Local to another server can be tricky.

When clicking the “Trust” button in Local, that basically is registering the Local site’s SSL certificate with the host computer.

In your case, it sounds like you are wanting the WordPress site to be making secure connections to some other server or api – does that sound right?

I’ve found that in general, using WordPress’ HTTP API helps to abstract a lot of the edge cases of negotiating that handshake.

Does using one of the wrapper functions help make those secure connections?

I had the same issue and discovered the only way was to bypass it using a Chrome trick built into the error page.

Just make sure the page is selected (click anywhere on the background), and type thisisunsafe

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.