Local Community

Windows 10 + IIS + VirtualBox Issues (and my fix)

Hi there, I have been running into the typical issues of starting up Local on my Windows 10 machine and seeing the message “Checking System” or “Loading Environment” (something like that, I don’t exactly recall what). Then I checked my logs and it was hung up on:
Successfully Loaded Environment: C:\Users…\AppData\Local\Programs\local-by-flywheel\resources\extraResources\environments\flywheel-1-3-1\out\environment.js

But Local never loaded up and the log made it seem like nothing was wrong. I’m sure Local would have noticed something wrong though, because on initial startup, the log should have shown some docker lines. Then I’d shut down Local and attempt to shutdown VirtualBox (in Task Manager) and would get errors. “Access Denied”. I even tried with Process Hacker and still couldn’t shut it down. The task was “VirtualBox Interface” or “VBoxSVC.exe”. This made me think that VirtualBox was the reason this wasn’t working (and yes, I installed the most recent version of VirtualBox on their site… 6.0.12 at time of writing)

Okay, so this is how I’m able to launch Local:

  1. Upon starting up Windows - search for the program “Internet Information Services”. Open it up. And then click “Stop” on the right side. I’m not sure if something changed with an update from Windows recently, but IIS seems to be the culprit here for all my Local issues.

  2. Open VirtualBox. Make sure VirtualBox actually opens and you see the Manager. You should also see “local-by-flywheel” and it should be turned off.

  3. Open Local by Flywheel. It should launch without issue.

My feeling is that with IIS running and attempting to launch Local and thus launching VirtualBox - it creates a conflict that can only be fixed by restarting your computer (I couldn’t find any other way. I tried killing VirtualBox every way that I could - even through CLI).

Hope this helps someone else!

1 Like

This is great. Thanks for sharing, Matt!

I wouldn’t have guessed that disabling IIS would help out with the VM not starting.