Won't Connect with Chrome iMac 10.1.6

I’m having serious problems here. I didn’t use Local for several months and now I can’t get it to connect to a local server on either of my machines. I’ve updated to the latest version and even started a brand new site, so that nothing old could be a problem and this is the error I get.

This site can’t be reached
gardeningbuddy.local refused to connect.
Search Google for gardeningbuddy local admin

It doesn’t matter if I use Chrome or Safari, I get the same error message. This is a huge problem, as I have several test sites that will no longer open and there is vital information I need to be able to get to. Plus I can’t develop any new sites, either, so I’m dead in the water.

My other is a MacBook Pro running 10.13.3 ( the latest, just updated).


Sorry for the trouble!

Can you please check the following?

  1. Is Local running?
  2. Is the Gardening Buddy site running? If there’s a gray circle beside it in the sidebar, click it to start the site
  3. If you click on to the site in Local, is there an orange bar at the top with a “Fix It” button? If so, click on it and enter your password.
  4. Do you have Gas Mask or other software installed that modifies your networking? VPNs can also conflict with Local’s VM.

Local is running. Gardenbuddy site is running. There was an orange bar at the top on one of the machines, so I clicked it. No orange bar on the iMac. I don’t have any other software running that could be a problem, as I’ve worked with Flywheel a bunch until around November, when I started a new job and had to cut back on my work. Only update I did was on the MacBook Pro to update to High Sierra, obviously the iMac isn’t that sophisticated…

When I click either Admin or Open Site I get the error message I stated earlier. I did not delete/overwrite the old Local, as I was concerned I might lose some info, but the MacBook opened up with all my sites showing, just none of them running.

Got it, thanks!

Can you try the following?

  1. Open Terminal
  2. Run the following command
rm -rf ~/Library/Application\ Support/Local\ by\ Flywheel/routes
  1. Right-click on the site you’re having trouble with and click “Restart”
  2. Check the site for any errors

If errors persist, please provide your local-by-flywheel.log file? See
"How do I retrieve Local’s log file?" for instructions on how to do so.

Should I do this with Local running?

OK, I tried running the below in terminal while Local was open on my MacBook Pro. Nothing happened. Could there be some extra spaces in the below listed command? I just copied and pasted it into terminal. I also tried typing it.

Here’s what has happened since I originally tried to open the site. I tried starting the GardeningBuddy site and it just sat on “starting site” for over ten minutes. So I quit the app. It said it would close all open sessions. I then tried to restart the app and it wouldn’t open. Got stuck on “ Local Machine Stopping.” So, eventually, after trying to start the app several times, I restarted my computer.

Tried opening Local again, which it did this time, and tried starting the site. Now it has been sitting there starting the site for a very long time. That’s when I tried the console command, hoping that I would be able to restart it from there, but no luck, unless there are other commands I need to do first.

My MacBook is stuck trying to start the site and I don’t know if there is a way to force quit it, other than to quit the entire app, which didn’t work out very well last time.

OK, got Local running on the iMac, Gardeningbuddy site is running, tried to open Admin and View Site buttons and still get the same error message.

Tried running the below listed command in terminal and nothing happened. This is what I see on both computers.

Sadaajits-MacBook-Pro:~ mysticwillow$ rm -rf ~/Library/Application\ Support/Local\ by\ Flywheel/routes
Sadaajits-MacBook-Pro:~ mysticwillow$

Left the computer overnight and it never did open the site. I forgot to say that there was an error message that showed up when I tried to start the site. Here’s the info

(HTTP Code 500) server error - driver failed
programming external connectivity on endpoint
(233f82f08e271854df33fdf9923c7fa6979943354b7e66d789a27437449c1185c): Bind for
failed: port is already allocated.

This morning I deleted the site from Local, as it was still trying to open. I then created a new file and tried to run it and am getting the same error message. How do I get out of this loop?