Do local has a cache system on wordpress sites?

I’m using a new site without plugin caches on it, just local as always, but, when changing styles the browser the old files and it is really annoying. Did local introduced this feature recently? How can I deactivate the cache on my site? There’s no cache plugins in it.

You can enable dev mode switch in local on the top right.
That should disable varnish cache.

Same here… dev mode is enabled by default but still files are cached.

1 Like

@Webtica I can not see the devmode on this site.

I see you are using a custom site instead of preferred.
I had a custom site aswell some days ago and when i would change for example some css in that project it would not change in google chrome but it did instantly on safari. on my mac.

If possible you can maybe try some other browsers.
i am not sure how to disable cache on custom sites but if possible you can export that site and import it as preferred and then enable dev mode.

1 Like

There isn’t a caching layer on the Custom environment. The only thing is standard browser caching with nginx/Apache.

If your browser is hard-caching assets you can hard-refresh by holding Shift then clicking the Refresh button.

Or, you can use the keyboard shortcut for your operating system: Cmd + Shift + R for macOS and Shift + F5 on Windows.


Dear Dev Team,
I am also struggling with the caching of php files. I did a change in theme php file (removed a breaking line altogether) but when I check the frontpage of website, php is still showing error on the same line. This is only possible when the local server is caching php output somehow. Please help me on this, how can I disable caching?

1 Like

I have the same issue. I’m working on a theme and none of the changes are showing.
I tried a lot of things like

  • cmd-shift-r
  • clear browser cache
  • output stuff in PHP and nothing happens
  • restart Local
  • restart computer
  • delete the files of the theme – nothing happened, still no change
  • deleted the entire themes folder with all themes – nothing happened, still no change

The only thing that worked was to go to WP-Admin, delete the theme there, go to the files and delete the theme and then upload the theme through WP-Admin.

Obviously this workaround is too time-consuming to actively develop a WP-Theme. I need instantaneous results.

I don’t see any way to tell LocalWP that I am in developer mode. Obviously this is too frustrating to keep using this product.

I have the same issue myself, just started using the product too.

After a recent windows update was pending and causing issues with speed of the software I reinstalled - now I have a cache porblem

In “customiser” or “design” view I see my changes but not on live site.

Anyone from Local care to support us?

I found an et-cache in my wp-content folder. Renamed it and presto changes loaded!
(and the folder got created again)

I do not have any cache plugin installed.

Seems this is a Divi Theme built in cache.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.