Error Installing Wordpress - The System cannot find the file specified

What issue or error are you experiencing?

This is the issue that happens each time.

I have gotten this a few times

I would also like to note that. This was working fine a couple weeks ago.

What steps can be taken to replicate the issue? Feel free to include screenshots, videos, etc

After answering the prompted questions for creating a new local site, it begins to do an install. I get a CMD popup asking for permissions. But other than that I get a pop up error. (This can be seen as the first screenshot above.)

System Details

  • Local Version:
    Version: 8.2.1

  • Operating System (OS) and OS version:
    Windows 11

Local Logs

Attach your Local Logs here (Help Doc - Retrieving Local’s Log)
local-lightning.log (958.0 KB)

Security Reminder
Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

Hi @Failure2Fly

If you change your Router Mode to Localhost are you able to proceed? Preferences>Advanced>Router Mode>Localhost

Do you have any antivirus, security, or firewall applications that could be blocking Local?

Are you running other developer applications simultaneously? That could also cause similar issues. Apps like MAMP, XAMPP, or Docker for example.

Hey Nick.

Thanks for the reply. I had saw this solution on a few other posts and they had not worked. (I tried the localhost one more just not to confirm.)

I am not running any other application such as MAMP, XAMP, or docker.

And I am not running any anti-virus, or firewall application myself.
(Although I’m not sure if Windows 11 does anything of that sort behind the scene that can affect. it.)

As an FYI.
Another solution I had tried from reading but did not work. Was in my main drive directory navigating to
Windows/System32/Drivers/etc and on etc opened properties and under attributes turned off “Read only”.
(Note it is back to Read Only as it was prior.)

Thank you for the detailed reply! Can you share your full log here for us so we can compare now? There are some different ways to access and share Local Logs. For us to be able to troubleshoot thoroughly, please click the Download Local Logs button from the Support tab in Local. This will generate a zip archive that contains the Local log along with some other diagnostic information to help quickly zero in on any issues that Local is encountering. (949.3 KB)

I still seems like something is stuck or conflicting here. In order to refresh here and start with a clean slate could you give the below troubleshooting steps a try?

  • Export any sites that you have on Local and save them to a folder somewhere on your computer.

  • Fully uninstall Local from your computer.

  • Install the latest version of Local on this link.

  • Once installed, please restart the computer.

  • When the computer is restarted and turned on, close any applications that automatically run in the background (AntiVirus, Firewall, and other Developer applications included).

  • Check and see if the issue still persists. If so, please provide us with an updated log so we can compare.

I took all steps mentioned above. Including making sure to uncheck all apps from running on startup.
Same issue persists. Attached is the new logs. (956.2 KB)

Hi there @Failure2Fly -

Does the admin_password contain any special characters?


No special characters that I haven’t seen used in a wordpress admin_password before.
Just (= and <).

Well Shoot that must of been it though. Something simple. Just had the wrong special characters. Thank you Sam.

1 Like

No worries @Failure2Fly -

There is a known issue with Windows + special characters in the admin password.

Thank you for checking and I’m glad it’s all working now!

Happy building,

Sam :green_heart:

Would you happen to know of a site for reference that mentions the characters that cause such an issue so I know which ones to avoid in the future?

I don’t think we’ve ever compiled a full list of the characters that cause problems. In general, you want to stay with a latin alphabet. So for example, don’t use characters with umlauts or other chars. I don’t think that would be an issue for you, but for example, on windows, many of our users with special characters in their username have problems due to how the MySQL process starts:

In the case of the issue you encountered, you mentioned being surprised that certain characters broke things even though you’ve seen them used in other instances of WP passwords.

You’re right that this is the case. If you wanted to, you could use the original password that caused issues by updating the password through the WP admin or through the “Forgot Password” workflow. This is because those form fields are more directly processed by PHP.

The reason that Local couldn’t use the password you used is because something within the password broke the cli command that Local used when creating the site (that gnarly error message is the actual wpcli command that Local runs to create the WP site).

I can’t see the full password in the screenshot, but basically, strings that have special meaning in the shell might cause issues. It’s challenging because I think there are differences between Windows shells and Mac/Linux.

Anyway, I know that’s not an official list of characters to avoid, but hopefully that gives a little background. As a rule of thumb, when creating a new site in Local, I’d stick with alphanumeric. If you really need to bring in special characters, update the PW within the WP admin.


Okay. Well nice to know I can just create a simple password and then update the password in WP once the site is created. Thanks.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.