Special characters not supported on Windows username/password

Moderator Note: Known Bug Summary

Thank you everyone who has chimed in and helps clarify this issue! The general problem is that when a Windows Username includes special characters (so an apostrophe ' or a non-ASCII character like é) it can break the commands Local uses to communicate with the MySQL database.

Usernames that have an apostrophe in them should be fixed, so update to the most recent version of Local if the username has an apostrophe in it.

Read on for what you can do if the username has other non-ASCII characters.

Upvote the Bug

If you are affected by this issue, please up-vote this bug by clicking the “Vote” button at the top of this topic. If you can, please leave a reply that mentions the username that is causing problems. This gives us a good idea of the various characters that are causing issues.


Due to the nature of this bug, the main option we recommend is to create a new Windows user that doesn’t contain any special characters.

If you want to live a little dangerously, take a look at the solution proposed by @Danniemite :

Original Message:

Hello! I got this error when trying to create a new site.
I attached a screenshot of the error and the log file.

Thanks for your time

local-lightning.log (53.1 KB)

1 Like

Anyone have any idea??? Please help!!

I’m having the same issue… Can’t find a solution

Hey all, sorry you’re having trouble with provisioning sites!

Would you try reinstalling/installing the latest beta build of local (5.0.7):
Try right-clicking the installer and “Run as administrator” just to make sure that installer can get everything it needs in place without permissions issues.

1 Like

OS: Windows 10
Downloaded the beta version and ran the installer as administrator. When trying to create a new site i get the same error as reported in this thread.

1 Like

I have the same problem. Installer Local 5.0.7 ran by Admin W10, but the problem persists. Could anybody help us ?

having the same issue. not finding any help. Was totally loving the speed of local by flywheel on linux too. sad.

I had this same issue ( using Ubuntu ) I had to purge the file and reinstall it on my administrator account using the software installer. For some reason when I install Local using dpkg it errors.

Having the same problem. Any good solution in sight…?



Having issues creating a new site with my wordpress login.
Get the following error message. Please see picture.

8 posts were split to a new topic: Unable to provision site on macOS older than 10.13 High Sierra

2 posts were split to a new topic: Database error importing site

Hey @gustafssonadam! Thanks for jumping into Local. We’ll see what we can figure out here.

What version of Local and what Operating system are you running there?

Can you please provide your local-by-flywheel.log file?

See this Community Forum post for instructions on how to do so > How do I retrieve Local’s Log?

local-lightning.log (150.1 KB)

here’s the log file

Hi everybody !

i have exactly the same error message than gustafssonadam

could the good team please publish the process to debug it here please, so that i will jump on local and start working.

my computer is with windows 10 and i try to “add a new site” on local v5-0-7.

i tried several times, restarting my computer before each try, i have also uninstalled-reinstalled local and it’s each time the same error message.

pleeease let me join :slight_smile:

ps : excuse my poor english

I have similar problem at Windows 10.


Can you help me to solve it

Hey @d4rk3c - There is a limitation in Local right now that prevents it from working when there are special characters in the path, such as the accent in the username here. We are working on getting this fixed for future versions but currently you will need to use Local version 3 or create a user that has plain latin characters to avoid the path issue.

Same problem. Whatever I try…


Hi all,

Thanks for your patience regarding this issue. I’ve made a note to look into this ASAP.

Any update on this error above ? I would like to use your service but can not find anyway to get around this problem