Error seemigly with Local trying to load an SSL cert that does not exist

Hi all,

Been using Flywheel for quite a while now and never really had any problems with it until now.

Tonight I decided to do some housekeeping my deleting unused or sites that are no longer needed in my installation of Local by Flywheel. Bad idea!

Now none of my sites are working.

I deleted the sites through the Local by Flywheel interface.

So when I try to visit any of my local sites in the browser I get the following error in Chrome:

This site can’t be reached
sitename.local refused to connect

I looked in the error log for Local Router and these lines appear everytime I try to load a site:

2019/03/29 23:00:03 [emerg] 1#1: BIO_new_file("/etc/nginx/routes/certs/gutenburg-test.local.crt") failed (SSL: error:02001002:system library:fopen:No such file or directory:fopen(’/etc/nginx/routes/certs/gutenburg-test.local.crt’,‘r’) error:2006D080:BIO routines:BIO_new_file:no such file)

I have tried navigating to the nginx folder but it does not exist. I was hoping that maybe I could copy another cert to try and get around this but as I say the nginx directory does not exist at all.

Gutenburg-test.local was one of the sites that I deleted. No mater what local sites that I try to load this is the error that is generated in the log file.

I have tried creating a blank gutenburg-test.local.crt in the location specified above to see if this causes the error message to change but it does not. Presumably the /etc folder is the one in the root of my Mac.

I am kind of at a lose here now that I cannot get any of my local sites to load.

Any suggestions would be greatly appreciated.

Hi Gareth,

Sorry about that!

Please try the following:

  1. Delete the routes folder. The path is dependent on your operating system.
    • Windows: %AppData%\Local by Flywheel\routes
    • macOS: ~/Library/Application Support/Local by Flywheel/routes
  2. Restart the sites you’re having trouble with