Error: stderr maxBuffer length exceeded

What issue or error are you experiencing?

Pulling an existing site from WP Engine to get changes and get the following error message:

Uh-oh! Unable to import site.
Error: stderr maxBuffer length exceeded

It only happens when I ‘Include Database’.

What steps can be taken to replicate the issue? Feel free to include screenshots, videos, etc

I can run the pull again. It happens every time.

System Details

  • Local Version:

  • Operating System (OS) and OS version:
    Ventura 13.5.1 (22G90)

Local Logs

Attach your Local Logs here (Help Doc - Retrieving Local’s Log) (39.9 KB)

Security Reminder
Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

Hi @robwp! Are you able to download a backup and direct import the site as a workaround? How large is it?

Hi Nick, I can do it that way I’m sure. The site storage is 4.07 GB. Not sure about the database. Can’t see the database size in the table structure in phpMyAdmin weirdly.

I just don’t like errors. And wanted the slick way of doing it to work. I hoped from the log you might be able to see what the problem was.

Is it not clear what the issue is?


I definitely understand that! Have you been able to pull this site in the past? Or other sites from WPE without issue?

Sometimes users are in a hurry to start working on their site so the import workaround is helpful to just get things moving along. It also helps determine if the issue is one with the site since it might still fail on import, or something interrupting the Local Connect flow. The logs are a bit sparse, and 4 GB isn’t necessarily a huge site but it is big enough that maybe some connection interference happened.

The specific error, ERR_CHILD_PROCESS_STDIO_MAXBUFFER has shown up in the past and is usually some type of issue with the database. If you get the same error when trying to do a manual import that could confirm the suspicions. In order to get the site into Local you might have to do a more manual approach.

The steps would look like this:

  • Download a backup zip of the site
  • Unzip the file in a common location, like the desktop
  • Create a new, blank site in Local. Use whatever username/password you like since you’ll overwrite the DB with this site archive’s dump.
  • Copy the wp-content folder from the unzipped location to this newly created site’s location
  • Copy the correct SQL dump to the site root.
  • Within Local, open the site shell
  • Import the dump with wp db import <dumpfile>
  • If that works, now Search and replace the domains. wp search-replace ' ' 'http:mylocalsite.local'

Hi Nick. I have 7 other WPE sites that were pulled in no problem. This problem site is in Local. I just get the error for the database. When I pull again for modified files and don’t tick the ‘include database’ checkbox it pulls in again fine. But if that is ticked I get the error. I’ll do a manual import of the DB and see if that fixes it. Thanks Nick.

Okay good to know! So all indicators seem to point to it being a problem with this specific site’s DB. The manual import might be the only way to get it in there if that’s the case, unfortunately. Keep us posted if you run into any other errors or roadblocks.

Hey Nick. Sorry, been snowed under with work. Just did a pull again for the site throwing up the error and it worked without a problem. Even when including the database. So it’s a bit of a mystery. Thanks for all your help.

1 Like

Hi @robwp Thank you for the update! Glad to hear it’s working again. If you run into any trouble again you know where to find us :slight_smile:

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.