Importing duplicator fails

I’ve tried dragging a Duplicator package and the first time the import completed, but:

  • The public directory container a bunch of strange files (e.g. Util_Widget.php, Util_WpFile_FilesystemChmodException.php and so on): they might be coming from the client’s site: I can’t check right now
  • The site’s custom theme was missing

I’ve deleted the site and tried the import again, this time selecting Apache and PHP 5.6: the import has been stuck on “Adding Site” for about half an hour and there is no clear way in the UI to cancel it, neither any progress showing where it’s stuck on.

I guess that killing Local will solve the last problem, but I’m still unable to import a duplicator package.

Sorry for the trouble!

Can you please provide your local-by-flywheel.log file?

You can get to it by going to Help » Reveal Local’s Log on macOS. To find it on Windows click on the 3 dots in the upper-right corner of the window then go to Reveal Local’s Log.


I’ve closed Local and when restarting it, it started like it was the first time ever, with the message “Welcome to Local by Flywheel!”:

Thank God I didn’t have any site there, yet, or I would have spent the week-end crying.

Anyway, here is the log:
local-by-flywheel.log (96.6 KB)

I can definitely see a bunch of errors there.

Based off of those errors I would recommend re-downloading Local to start with.

Also, can you try checking/repairing your disk using Disk Utility? There are quite a few errors in the log that are indicative of potential disk issues.

I gave another chance to this:

  • Reinstalled Local
  • Checked my disk with Disk Utility: I don’t know what you’ve seen in the logs, but there were no issues as all
  • Tried to import the Duplicator package: it went through it
  • Opened the site from the back-end: content is there, the theme is gone

I think I’ll give up but, just in case, here is the log file again: local-by-flywheel.log (19.1 KB)

The zip file I’m importing has the theme, of course.

Also, I’d really like to know what is all the stuff i see in the public folder.

This is only the top of the list, as I couldn’t take a screenshot of such long list of files: