Live Link Connection not working

Issue Summary

Live Link is not working well using a WP website with Elementor and Elementor Pro. There seems to be a connection but with the message (translated Dutch into English): ‘all rights reserved’
See attachment

Troubleshooting Questions

  • Does this happen for all sites in Local, or just one in particular?
    There is difference but I don’t know why: When I create an new Wordpress website. In this case you have to put in your login data again and again and again instead of the message

  • Are you able to create a new, plain WordPress site in Local and access it in a Browser?


  • Create a WP Website worth Elementor and Elementor Pro.
  • Switch on Live Link
  • copy login data
  • test to login from from another IP

System Details

  • Which version of Local is being used?
    6.7.0+6354 (latest)

  • What Operating System (OS) and OS version is being used?
    Windows 11

  • Attach the Local Log. See this Help Doc for instructions on how to do so: (25.5 KB)

Security Reminder

Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

Attachments: (25.5 KB)

Additional: the attachment shows a page, so the connection is working! But how to proceed fom this page? There is no menu or something like that.

Hi there @Lorens - welcome to the Local community! :wave:

Sometimes there are issues with images and the way things display generally over Live Links with Elementor and other similar builders.

There are some suggestions in this thread I would recommend trying:

Let me know if anything in there helps, we’ll get this figured out!


Hi Sam,

The first steps are not so easy for me. But I don’t think it has something to do with images. I tested 2 situations: 1) WP Website with plugings Elementor and Elementor Pro and with Advanced/ CSS Print Method = Internal Embedding. I created in Elementor just 3 header templates, no pages yet. 2) I created also a WP Website with no plugins at all. I read only the remark that to use WP Local Live Link Helper. But unfortunately I could not find this plugin. In both cases my wife tested from another location (other IP) to login. She got the same result in both cases: just one single page in the browser, but no possibility to progress. There is no menu at all (see attachments) .

Some questions:

  1. Please can you test this also the connection, because it seems there is a connection, but maybe there is something wrong to display the correct result on the laptop of my wife?
  2. Do I need WP Local Live Link Helper? If so, how to find this?
  3. Why does my wife get just one page. Is there something wrong in the setup of WPLocal? What should be the result?

Best regards,
Lorens Knap

Hi there, @Lorens -

To clarify, are you having an issue with the pop-up login credentials from Live Links?

If you’re having issues with the site looking differently over live links, did you try Ben’s suggestion to change the “CSS Print Method” (see the Elementor Docs: Settings | Elementor)


Hi Sam,
Using the pop-up credentials from Live Link the result is a just a browserpage. I am not sure what I should expect, but at least I expect possibilities to be able to change things in Wordpress, correct? I changed 2 things: 1) I used CSS Print Method = Internal Embedding 2) I created a Home Page and defined this as a static page. But still the same result: a browserpage - see attachment. Can you tell what I should see?

Best regards,
Lorens Knap

Hi @Lorens -

Can you show me what you see on the Local version of the site? Is it the content that’s missing?



Hi Sam,

See attachment.

Maybe good to have some things clear: I am new to localwp, and I am expecting from Live Link that is it is possible to get for example support on technical issues, right? After using the credentials from localwp, the result is just a browserpage. It is not exactly clear to me which data is shown, because it is a little bit messed up, but it is data I created. And this browserpage is all! No wp-menu, no way to proceed. Do I miss a setup or something like that? Or should I just get a browserpage?

Meanwhile I created a Header Template in Elementor and a (begin of) a homepage (reading settings: static).
CSS Print Method = Internal Embedding.

Best regards,
Lorens Knap

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.