Live Link doesn't work after importing w/Duplicator

I figured out the only way to move a live site to Local was to delete the auto-generated files out of /public in my auto-generated Local site and then drop the Duplicator .zip and installer.php file in there and run them.

That worked but it broke the Live Link functionality.

Are there a few files that re-enable the Live Link functionality?

Before you make other suggestions about how to import the files, maybe I can save you some time:

  • I already tried simply zipping the .sql and wp-content directory. That didn’t work (broken hosts file I have no idea how to fix)
  • I also tried simply dropping the duplicator .zip entirely on Local to import it and that did not work at all either and with the same results.

BTW, I can’t access the Database or Utilities tab on any Local sites, not even a fresh auto-generated install. So, that’s possibly why I can’t fix the Warning messages about the hosts file. Maybe Local is just not full working on my system because it seems like I should be able to click the Database or Utilities tabs.

Without the Live Link feature, there’s no reason for me to use this over MAMP. The HTTPS does nothing; I still had to disable my WP Plugin for HTTPS just to get the site running on localhost (local HTTPS was the whole reason I tried Local, actually). I stuck around trying to get Local to work just because the live link feature looks cool. But, if there’s no live link feature, then unfortunately there is nothing Local beats over MAMP, which is sad. Because I really dislike MAMP at this point.

Hi Nate,

Thanks for the details!

Can you please provide your local-by-flywheel.log file? You can find it by going to Help » Reveal Local’s Log (macOS) or by going to the menu in the top left and clicking on “Reveal Local’s Log” (Windows).

Also, if privacy allows, is there any way you can e-mail me the Duplicator backup so I can troubleshoot what’s going on? Feel free to private message the link to me here on the forums if you can.

Hi Clay

I experience the same issue with duplicator also with all in on migration tool. Live link stop working after restore the site from backup.

Can I email you the log?

Hi all,

Same issue with all in one migration tool. Any update or solution? I’m testing your app to go in production with the pro version. But it seems the support is not solving this issue in threads I have found.