Local 6.7.2 not opening under windows 10

Issue Summary

I have installed the latest version of local on my pc but it doesn’t open. Read a similar topic but did not find a solution (I have Nordlayer disabled)

System Details

  • Which version of Local is being used? 6.7.2

  • What Operating System (OS) and OS version is being used? Windows 10 Professional

Hello @hono -

When you say that it won’t open, are you receiving any errors? Have you tried to reboot your machine?


Hi Sam,

I don’t ave any errors just nothing is happening and yes tried to reboot but nothing changed.

Hi @hono -

Have you tried uninstalling and reinstalling Local?

Have you tried to downgrade the version of Local you are using?

You can also try ensuring you don’t have a firewall or Antivirus preventing Local from opening.



I have tried everything above and nothing worked even uninstalled my VPN

I have Bit defender. Could that be an issue? UPDATE I have upgraded to W11 to see if it worked. It doesn’t :frowning:

Hi @hono

Bitdefender could be the cause. Can you check this?

Hi @Nick-B ,

I uninstalled Bit defender. Turned off and on my computer. Local is still not opening at all. :sob:

Hi @hono

Does changing your Router Mode make any difference?

Have you tried this yet?

If you’re still having trouble you could try these steps:

  • Stop all sites that are running in Local

  • Force quit Local

  • (If using Mac) Run the command lsof -nP -iTCP -sTCP:LISTEN

  • (If using Windows) Run the command netstat -ano

What you’ll be looking for here is to see when sites are stopped and Local is properly shut down if there are still programs running on ports 80 and 443. These may be conflicting with Local or the system may be reporting Local is still running.

Once you run that command you should see a list of listening ports. If you see a particular program making use of those ports, you can then kill that process by running sudo kill -9 XXX where XXX is the PID number of that process. (On Windows you will use taskkill /F /pid XXX where XXX is the PID number of that process)

After that, you should be able to retry. Keep us posted if you have any questions or continuing issues.

There are also some more details around this and other troubleshooting steps at this link if needed: Stopping Whatever Is Listening On Port 80.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.