LOCAL hangs up/crashes "Starting up Site Services" 2023

What issue or error are you experiencing?

LOCAL used to work great! a few years back, same computer but running an earlier OS. I think the version was 5.xxx and maybe 6.xxx.

Starting up Services never completes itself. Force quit LOCAL, restart LOCAL the attempted website is listed but does not open, click on FIX IT but nothing happens. Database shows this:

What steps can be taken to replicate the issue? Feel free to include screenshots, videos, etc

It happens every time. I even switched to a bare bones USER and got the same results.

System Details

  • Local Version:

Latest, 7.2.0

  • Operating System (OS) and OS version:

Mac, Big Sur

Local Logs

Attach your Local Logs here (Help Doc - Retrieving Local’s Log)

local-logs.zip (4.4 KB)

Security Reminder
Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

Welcome back to Local! Did you just install 7.2 from scratch or did you upgrade from one of the previous versions?

In order to refresh here and start with a clean slate could you give the below troubleshooting steps a try?

  • Export any sites that you have on Local and save them to a folder somewhere on your computer.

  • Fully uninstall Local from your computer.

  • Install the latest macOS version of Local on this link.

  • Once installed, please restart the computer.

  • When the computer is restarted and turned on, close any applications that automatically run in the background (AntiVirus, Firewall, and other Developer applications included).

  • Check and see if the issue still persists. If so, please provide us with an updated log. Retrieving Local’s Log File

Keep us posted and we’d be happy to help further!

local-logs.zip (3.6 KB)
Did everything as described, still the same, no change. The only app I didn’t shut down was Chrome, but that should not matter.

I looked, I have the hosts file. I removed all the old local/flywheel stuff, no change, still stuck. I get an error at the top saying can’t something or other with hosts file, want to Fix It? Fix It never works. I also can’t delete the site that shows up but won’t start. Also hangs up on “Deleting…”

It looks like something on the machine might be preventing Local from making changes/updates.

Are you running other developer applications simultaneously? That could also cause similar issues. Apps like MAMP, XAMPP, or Docker for example.

Do you have any additional antivirus, security, or firewall applications that could be blocking Local?

More details about troubleshooting this here: Router Mode

No. I didn’t download any of those until after LOCAL would not work. Now it’s all deleted.

When you have Local running, if you change your Router Mode to LocalHost does that allow it to work? Preferences>Advanced>Router Mode>Localhost

I have to set up another site to do that I’m guessing

It’s not a site-by-site setting but a setting for the app as a whole. So you should be able to just navigate to in your app right now. Details about this are in our help article below:

Uh-oh! Unable to start the site.

Site won’t start. New “Test” site hangs up on “Starting up Site Services”

This is after changing your Router Mode to Localhost?

Can you try Quitting Local, and then opening it back up and see if it works then?

“test” site gives me this:

404 Forbidden

Looks like it’s installing WordPress now.
Yeah, it worked! WooHoo!

I’m glad to hear it @chrisborgman!

Thank you for your patience and communication here. If you need anything else you know where to find us :green_heart:

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.