LocalWP won't start on my laptop after update

What issue or error are you experiencing?

I updated Local automatically from 8.3.2 to 9.0.1 and it won’t start. I have tried everything including checking firewall and antivirus to ensure it’s not blocking Local, restarting my PC, uninstalling Local and downloading and installing the lastest version, uninstalling that version and installing the previous version.
I can’t even get logs because when I check lightning-log using command prompt, I get an error message. I tried opening the app using command prompt and also got an error message. I have attached both.

What steps can be taken to replicate the issue? Feel free to include screenshots, videos, etc

System Details

  • Local Version:

  • Operating System (OS) and OS version:

Local Logs

Attach your Local Logs here (Help Doc - Retrieving Local’s Log)

Security Reminder
Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

Are you running other developer applications simultaneously? That could also cause similar issues. Apps like MAMP, XAMPP, or Docker for example.

Have you tried changing your Router Mode? Preferences>Advanced>Router Mode

I don’t have any other developer apps running. Also, is there a way to change to router mode without being on Local since it won’t even open?

Apologies I thought you were unable to start your site not that you couldn’t get into Local at all.

Is this a work machine or a personal one? On your machine are you using an admin user?

Do you have any antivirus, security, or firewall applications that could be blocking Local? Anything like this for example? Help! I'm running into an EPERM error with the hosts file on Windows

Yes, the machine is a personal one and I’m the only admin/user.
No, I already checked antivirus and firewall and that’s not it. I also checked to make sure read only is not selected

I solved the issue by uninstalling local and deleting all affiliated files then I installed the latest version and it worked.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.

Thank you for sharing @Mathaytu! Happy Developing :green_heart: