SSL - Never receive a Green Padlock...ever

Hey there!

I LOVE Local and not sure how I’ve lived without it. It’s an incredible tool that just makes development awesome again! :heart_eyes:


The Local by Flywheel landing page say’s:

Any site created via Local by Flywheel will automatically have a self-signed certificate created. Green padlock achieved!

I’ve never received or achieved a Green padlock. I “Trust” the certificate in Local, add the exception when prompted in Firefox but no joy.

Here’s what I get in Firefox:

Chrome is even more aggressive.

This also leads to having SSL issues when working with AJAX (with third-party services - I have to use jQuery linked from Google and not my WP install) and simply never plays nice unless I remove the https from the URL with every page I visit from a development site.

What would I need to do to achieve that elusive green padlock so I know that the SSL is truly working properly?

Thanks for your help! I really need to get this sorted :wink:

Hi Alex,

Are you running Local 2.0+?

Assuming you’re on Local 2.0+ and macOS, here’s what you can do to force the certificates to update.

  1. Browse to ~/Library/Application Support/Local by Flywheel/ and remove the routes and router folders
  2. Restart any site in Local
  3. Check the certificate

Local creates a fake SSL certificate with your website’s .dev name in the Mac’s Keychain database.

You may have to remove this fake SSL certificate from your Keychain and create a new one in the SSL feature of Local so that Google will trust your development website.

1 Like

Hi @Clay,

Yes - I’m running Local 2.0.3. I’ve been using Local since the day it was released by Flywheel and have upgraded manually until the auto-updater came out.

On forcing the certificates to update I’ve:

  1. Deleted the routes and router folders
  2. Deleted all exceptions previously added in Firefox
  3. Removed ALL instances of the certs added to Mac’s Keychain DB (thanks @marianco!)
  4. Restarted the site in Local
  5. Attempted to visit the restarted site via the “View Site” button in Local
  6. Received the Firefox error that I needed to add an exception
  7. Added the exception to Firefox
  8. Still no joy and all is the same

Still receiving the “Not Secure” warning by Chrome as well.

I’m happy to try anything else that may help solve this mystery.

Thank you both for replying and helping me out on this!

1 Like

Did you click on the “Trust” button in Local under the SSL tab? This will add it to your system keychain.

Ha! No - I did not… figures right?

So I went through every step above exactly once more with that addition:

  1. Deleted the routes and router folders (well, only routes, router never returned)
  2. Deleted all exceptions previously added in Firefox
  3. Removed ALL instances of the certs added to Mac’s Keychain DB
  4. Restarted the site in Local
  5. Clicked the SSL tab in Local and then clicked on the “Trust” button - it now shows “Trusted”
  6. Attempted to visit the restarted site via the “View Site” button in Local - Firefox is my default browser
  7. Received the Firefox error that I needed to add an exception
  8. Added the exception to Firefox
  9. Still no joy in Firefox but…

Chrome, however, is now working as expected! Green Padlock Achieved! :smiley:

Any idea why it remains the same in Firefox?

Are you able to achieve a Green Padlock in Firefox?

Thanks again for your help!

Haha, no worries! Glad it’s working in Chrome though :slight_smile:

Based off of a quick Google it looks like Firefox is a little more picky and doesn’t read straight from the macOS keychain.

Here’s something that I found that may help:

YES! Working in Chrome :smiley:

Thanks for the article. Firefox walks you through doing this but I went ahead and tried everything above again except this time I manually entered the exception in Firefox - still no joy there though. It was worth a shot!

I’m still curious though - are you able to achieve a green padlock in Firefox on your side or if it’s just me.



Sorry to jump on this months later, but I have what is probably a very easy-to-answer question: Where is the library folder? I’m having the same issue with SSL certs and can’t find it.


The easiest way to navigate to Local’s folder in ~Library is to:

  1. Open Finder
  2. Go to “Go » Go to Folder…” or press Cmd + Shift + G
  3. Enter ~/Library/Application Support/Local by Flywheel/

What’s the Windows equivalent?

On Windows, you can open Explorer and enter %AppData%\Local by Flywheel into the location bar.

Aha, there we are. Thanks.

1 Like


Thanks for a good thread. A couple of questions. I’m on Win 10.

It still not working for me in Chrome. I tried to delete the routes folder, but could not find the router folder. I am running an Apache environment. How will I know when the certs have been updated? Mine says OpenSSL version 1.0.1t 3 May 2016.

In Chrome it doesn’t even load the stylesheet. Chrome says it unsafe script. If I click and tell Chrome to disregard that and accept the unsafe scripts the site loads ok. But not over https. Not even in admin area. I also get errors running ajax in the admin area because chrome will not load a bunch of scripts - it blocks them and because of not being on HTTPS.

I don’t get the site over HTTPs in Firefox, but at least it works as expected and is usable in the admin area without Ajax errors.

Hi @davidglx,

After you click the “Trust” button in the site’s “SSL” tab, restart Chrome. Chrome on Windows requires a restart unlike Chrome on macOS.

Hi Clay,

Thanks for the reply!

That did however not work. Maybe there something else that is the problem.

  1. When I open the site in Chrome I get certificate valid, but it doesn’t load the scripts. There is an icon in the address bar with a shield and red x on it. If I click it it asks if I want to load the unsafe scripts - These are all scripts that are loaded locally. Then the site reloads with stylesheets and scripts and renders as it should. However it does not get a green https, it is red and it says unsecure. That causes problem for me in the admin as well as other places.

  2. If click trust in SSL in Local it changes to trusted. But if I click Site setup and then back to SSL it no longer says Trusted instead it says Trust.