Team downloading same site from WP Engine through Connect, but certain site functionality only works for some

What issue or error are you experiencing?

My team is new to LocalWP so apologies if there’s a simple oversight on our part. We are downloading the same sites from WP Engine through LocalWP’s Connect. However one of our plugin’s functionality is consistently working for one team member on both sites, working on one site for one team member but not on another, and consistently NOT working for another on both sites.

Site #1:

  • Works for team member 1
  • Doesn’t work for team member 2
  • Doesn’t work for team member 3

Site #2:

  • Works for team member 1
  • Works for team member 2
  • Doesn’t work for team member 3

What steps can be taken to replicate the issue? Feel free to include screenshots, videos, etc

We have tried deleting and redownloading the sites through LocalWP Connect. I’m not sure how this could be replicated.

System Details

  • Local Version:
    Team member 1: 7.1.2+6410
    TM2: 7.1.2+6410
    TM3: 7.1.2+6410

  • Operating System (OS) and OS version:
    TM1: Windows 11 Version 22h2 (OS Build 22621.2134)
    TM2: Windows 11, Version 10.0.22621 Build 22621
    TM3: Windows 10, Version 22h2 (OS Build 19045.3324)

Local Logs

Attach your Local Logs here (Help Doc - Retrieving Local’s Log) (41.3 KB) (32.1 KB) (56.8 KB)

Security Reminder
Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

Hi @Jackie

Can you give us more details about the plugin and the plugin’s functionality that aren’t working correctly/consistently?

This is a custom build plugin from our team. It’s a resource center with some links that redirect to the resource PDF in certain instances. The functionality that isn’t working consistently is this redirect and when it doesn’t work we just get a 404 error.

Ah okay, thank you for the insight! Off the bat, you mentioned the problem being a redirect that sometimes hits a 404 error. Is there any difference in work environment between the team members? I’m wondering if the users having intermittent issues could be running into network connectivity, firewall or VPN troubles.

The errors in the (which I assume correspond to Team Member 3) indicate they might have a security, antivirus, firewall, or possible other developer applications that are interferring with Local. Apps like MAMP, XAMPP, or Docker for example can cause these types of issues. It’s also common for Windows users to run into security blockers with Defender, permissions, etc

Keep us posted and we’d be happy to help further!

It appears it was just a permalink issue! Refreshing the permalinks solved the problem :+1:

1 Like

Glad to hear it @Jackie! Thank you for sharing. Happy Developing :green_heart:

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.