Trouble pushing site to WP Engine

I’ve been having the same issue. Should I start a new thread or can you help me here? In the meantime i will log in and out of wpengine. I am having trouble pushing, have not tried pulling since i have been editing locally. Mac, Sonoma 14.4, WPEngine, latest version of local (just updated and did not fix my problem.) I have my log downloaded, but will wait to find out if i need to start a new thread. Thanks!

Thanks for writing in @studio4sls – I moved your reply to a new topic.

Can you describe the issue in a little more detail as well as include the logs? Also, what version of Local are you using?

1 Like

Thanks! I just updated to the latest (Beta) this morning, in case that would help. Version 9.0.2+6676

I try pusing to staging on wpengine and get an “Uh Oh! (something about being unable to push to wpengine)” However it just asked me to login in to local, then open a browser tab with this message:



I ran into that message a year ago or so but cannot remember what the fix was? I think i needed to create a new api and somehow connect it? I am also attaching my log, just in case: (52.6 KB)

Thanks for any suggestions or help you can provide.

I was able to fix that 403 issue by logging in and out of the connection. But none of that fixed the issue - @ben.turner. Message i get is “Uh Oh! We ran into an issue when pushing to WPEngine.”

Here is the latest log: (54.7 KB)

Thank you for any advice or help you can offer.

Thanks for those logs @studio4sls !

I think the issue might be related to this line:

{"class":"RsyncService","level":"warn","message":"rsync: [generator] delete_file: unlink(wp-content/mu-plugins/wp-cache-memcached/includes/wp-object-cache.php) failed: Permission denied (13)\nrsync: [generator] delete_file: unlink(wp-content/mu-plugins/wp-cache-memcached/includes/stats.php) failed: Permission denied (13)\nrsync: [generator] delete_file: unlink(wp-content/mu-plugins/wp-cache-memcached/includes/memcached-adapter.php) failed: Permission denied (13)\nrsync: [generator] delete_file: unlink(wp-content/mu-plugins/wp-cache-memcached/includes/memcache-adapter.php) failed: Permission denied (13)\nrsync: [generator] delete_file: unlink(wp-content/mu-plugins/wp-cache-memcached/includes/adapter-interface.php) failed: Permission denied (13)\nrsync: [generator] delete_file: rmdir(wp-content/mu-plugins/wp-cache-memcached/includes) failed: Permission denied (13)\nrsync: [generator] delete_file: unlink(wp-content/mu-plugins/wp-cache-memcached/object-cache.php) failed: Permission denied (13)\nrsync: [generator] delete_file: unlink(wp-content/mu-plugins/wp-cache-memcached/.dockerignore) failed: Permission denied (13)\n","thread":"main","timestamp":"2024-05-22T21:01:49.948Z"}

This is due to the new Memcached plugin that is being rolled out on a number of WP Engine’s servers.

The latest version of Local, 9.0.3 has an update to address this. Can you try upgrading and pushing the site again?


@ben.turner awesome, that worked! It’s fixed. Thanks so much!


Thank you for letting us know @studio4sls! :green_heart:

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.