Uh oh! Unable to pull site (permissions issue)

I’m trying to install Local 7.1.0 on my Windows 11 machine and it’s failing to create the database and wp-config.php file.

I have tried using older versions of the Local software from the releases page, I’ve completely removed Local using the instructions on support pages (Uninstalled application, removed AppData folder, and deleted local sites, then restarted) numerous times but I can’t understand why.

Tried everything, different site names, different environment settings, can’t understand why as I can access that folder, even ran the application as an administrator. Never had any issues when using my Mac.
local-logs1.zip (2.4 KB)

System Details

Version 7.1.0

Windows 11 Pro 10.0.22621 Build 22621

Local Logs

Hi @dan4duk

Windows users often run into more security and permissions issues so there might be something blocking local like security, antivirus, or firewall protection.

You could start by checking here: Help! I'm running into an EPERM error with the hosts file on Windows

Are you running other developer applications simultaneously also? That could also cause similar issues. Apps like MAMP, XAMPP, or Docker for example.

None of those installed (MAMP, XAMPP, Docker or anything that runs an Apache/nginx server or uses any ports 443/80 etc.

Host file allocates file, oddly if I create the site manually via a WP Engine backup ZIP everything works as expected.

I’ve disabled AVG Antivirus and firewall, can’t see any reason to throw the permission issue:

So is this happening when you are trying to create a new, blank site or specifically when you use Local Connect to pull directly from WPE?

I’m glad direct importing is working normally!

When using Local Connect to pull from WPE

You might need to try resetting your API credentials if this is your first time pulling to this machine using Local Connect + WPE

Sadly not, I reset the credentials 4 times.

If you take a look at the logs, it looks to be a permissions issue…

It looks like something still might not be syncing right with your SSH key. Something that might help would be deleting your credentials, logging out from your Local WPE connection, and then regenerating credentials and logging back in. This might help to force things to resync!

I am having the same issue after pulling a site form WPEngine to Local on a Window 10 Pro machine.

I tried what you suggested… plus I created a new local/empty site and then connect it to the functioning WPEngine site and initialed the pull. This seems to have complete successfully, but the site will not load corrected… various PHP errors are displayed the seem to indicate file permission errors.

“Access is deni (code: 5)”

If I look at the actual folders referenced I get a message about incorrect permissions on the active theme folder.

Are these PHP warnings or critical errors? Can you share a screenshot or copy paste some of the errors here?

Do you have admin privileges on your machine? Are you on a work computer/machine?

PHP Errors - they indicated that various required files that trying to be included from the theme cannot be accesses.

When I navigate the theme folder on my local environment and get this message and cannot access it.
Capture (2)

This is personal machine and I do have admin access. I tried running Local as admin and doing the pull - same issue. I was able to recover by downloading a ZIP of the wp-content folder and manually adding it to my local site.

I have not had this type of issue in the past, working on dev sites with Flywheel or WPEngine.

Great to get this resolved so I can smooth out the process again and it this not working for me anymore.

It’s strange that it’s only suddenly come up, but googling the error in the screenshot I can see it’s something many Windows users have come across. This might be helpful in addressing:

Thanks for the feedback Nick

This doesn’t seem to be a one off, I would rather not have to run scripts every time I pull from WPEngine.

I did some more testings:

  1. Created a new default site in Local (v7.1.2) / Windows
  2. Created a new default site in WPEngine
  3. Pushed Local to WPEngine
  4. Test site WPEngine - Seems fine
  5. Pulled to Local
  6. Site loads, but I get PHP warning … /wp-content/mu-plugins): Access is deni (code: 5)
  7. An if I try an delete the folder in Windows I get a permission error, even when using admin options.
  8. If I try to push the site back to WPEngine I get the red error message at the top of Local:
    Uh-oh, We ran into an issue when pushing to WP Engine.

If you reset your API credentials and test this again is the result the same?

I did that Yesterday, but have done it again today following the above link.

No change… It seems once I push to WP Engine the site gets changed and no longer works In Local as expected.

  1. I can can’t pull the site without php errors related to permissions issues
  2. I can push the site back to WP Engine… I get the “Uh-on” error message
  3. If I try to clone this site in local it hangs and never completes

FYI - Cloning as site that use not been pulled from WP Engine works fine.

Thank you for all of the details and troubleshooting! It’s interesting it mentions the mu-plugin that you mentioned earlier.

Did this start happening after the most recent update? You mentioned it has otherwise always worked normally when connecting with WPE correct?

I haven’t used Local → WP Engine for a while, but did update Local this week.

FYI - I am testing with Flywheel now.

I would try uninstalling Local and re-installing, but worried I would loss all my local sites

I don’t think a full uninstall/reinstall will be necessary so I’d hold off on that. If it does come to that though you can always export your sites and save them for importing later or use our Cloud Backups Add On!

Thoughts on rolling back by installing a v6.x.x version of local?

Hold off for now and let me check with the team on this!