Unable to restore cloud backup, but I am able to clone site from backup

I am backing the site I am working on to my Google Drive. But if I try to restore the site any of the backups, i receive an error. Error is pretty vague, only saying “there was an error”.
I am, however able to create a clone of the site from any of the backups, which is fine, but not really an optimal solution.

System Details

  • Local Version: Version 8.1.0+6514

  • Operating System (OS) and OS version: Windows 11

Hi @SandiaCreative

Could you share a copy of your Local Log? There are some different ways to access and share Local Logs. For us to be able to troubleshoot thoroughly, please click the Download Local Logs button from the Support tab in Local. This will generate a zip archive that contains the Local log along with some other diagnostic information to help quickly zero in on any issues that Local is encountering.

local-logs.zip (114.9 KB)

I apologize, I thought I did attach it in the message

Are you using Avast Antivirus? Or any other type of security applications/extensions? It’s possible these might be blocking the backup restore.

I tried with Avast turned off and the error persist. If it was the AV issue, wouldn’t I have the same error when cloning the website from a backup? Because I only get the error if I want to restore the website to a backup.

You’re not wrong. It’s just hard to narrow down the specific culprit. This error is repeating in your log which indicates something on the machine isn’t playing nicely.

2023/12/16 13:17:30 [error] 9392#9972: *1436 connect() failed (10061: No connection could be made because the target machine actively refused it) 

Have you tried disconnecting/reconnecting your Google account?

If you haven’t yet, it would also be worth trying a Local reset:

  • Stop all your sites
  • Log out of your Local User
  • Quit Local
  • Restart your machine
  • Open Local back up, sign in and try again

I tried reconnecting my Google account, I disabled both av and firewall, I did the steps you provided, but the error is unfortunately still happening.

Thank you for looking into this

I’ve been testing this on my own Local app and can replicate the issue. So there might be a deeper conflict with the latest Local release and the Add On. I haven’t been able to figure out a workaround yet other than going through the Cloning process as you discovered. I’ll check with the Dev team on this and report back! I’m glad the Cloning is at least working as an alternative for now.

1 Like

Ok, well, I am at least glad you were able to replicate the issue, as that means it’s not just a me problem :slight_smile:
Thank you again for your help, and I hope the solution comes soon


I’ve been trying to restore my backup from google drive on local app again with Cloud Backup add-on for 2 days now, the process gets stuck at “Changing Site Domain”.
this is going for at least 2Hours now, and nothing changes.
I also tried to restore my backup with Restic, after making a zip file and drop in local application, it just gives an error of not a compatible Zip file!!

Hi @General.Mamali

I’ve moved your comment to this post since that other one was over a year old and is now closed. We are tracking a recent issue with Cloud Backups here. As a workaround are you able to Clone the site instead of Restore?

Regarding the zip file error it might be because there are some files confusing the Local import. As a workaround you can unzip the file and do a manual import with the steps here:

@SandiaCreative Please could you try making sure that the site is running before trying the restore? This line from the logs you kindly supplied suggests the site is not running when the restore attempt was made:

… "message":"Database did NOT respond to ping after 15 tries." …

I can only reproduce the restore failure if the site I’m restoring to is not running.

I’m sorry that the error message was not more clear! I’m looking into improving that now for future versions of the backups add-on.

Hi Nick.
I have tried it both ways, with the site both running and not running. I tried many things before deciding to submit a ticket.
I was working on the site, so it was obviously running at the time, when I wanted to revert to one of the backups. I got the error, so I tried some other restore points, but also got the error. Tried some other things I googled for (I can’t really remember exactly what right now). Then I tried with the site not running, to see if that might work. It didn’t make sense it would in my head, but I wanted to give it a try.
My understanding is @Nick-B was able to reproduce the failure to restore?

Hi @SandiaCreative - I was doing some testing again yesterday and I was able to get the Cloud Backup restores to work for me on new sites. I had a couple of older sites I was testing with previously that were getting hung up on a certain plugin folder. Once I deleted that I was able to restore those as well.

As a test could you try these steps?

  • Disconnect your Google Drive
  • Log out of Local
  • Quit Local
  • Open Local back up and Log in
  • Reconnect Google Drive
  • Start your site
    *Attempt to restore

If it errors out again send us a fresh Local Log and we can see if anything has changed in there!

Hi @Nick-B, weirdly enough it seems to be working for me now too! I say weirdly, because I literally haven’t done anything differently or changed anything.

Just out of curiosity, is there any explanation why it might have been happening?

Thank you for your help!

1 Like

Hi @SandiaCreative - Well that’s good news! I’m glad things are back to normal. I’m not entirely sure what else could have interrupted this but as @nickc mentioned our Devs are looking into some better error messaging to help narrow down a root cause should this type of thing arise again.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.